remote desktop - xrdp from Windows 7

18
2014-04
  • Walter

    I installed xrdp on my new Ubuntu Server 12.xx I saw a video that talked about creating a .xsession because of the 3D and 2D desktop. But it didn't work.

    If I take the .xsession out it opens a empty desktop with no icons on it.

    This is the content of the .xsession file.

    gnome-session --session=ubuntu-2d
    

    Any suggestions?

  • Answers
  • pablodav

    Please check my answer here:

    Remote desktop for multiple users

    X2go and ssh Works with better support and features for linux remote desktop. (Like, file sharing, clipboard sharing, sound over net, web client, etc).


  • Related Question

    Unable to do remote desktop using xrdp
  • user1667630

    I have a virtual machine (ubuntu) to which i need to do remote desktop. I do not have physical access to that machine and I can do only ssh to the machine. I wanted to do remote desktop and came up with lot of options (vnc, xrdp, opennx). I used xrdp and I installed the necessary packages in the ubuntu machine (xrdp and dependent). Then I enabled the remote access in the ubuntu using the following command line option.

    gconftool-2 -s -t bool /desktop/gnome/remote_access/enabled true

    gconftool-2 -s -t bool /desktop/gnome/remote_access/prompt_enabled false

    Then I restarted the xrdp (/etc/init.d/xrdp start). But when I try to do rdp using the windows client (mstsc), I get the following error. Remote access to the server is not enabled.

    How do I solve this. Kindly help.

    Raj


  • Related Answers
  • jamjam

    sudo ufw disable

    then try logging in using your rdp.. client software. I am in the process of setting this up for 12.04 linux vps, so far i got connected but not seeing a desktop only a command window.

    Hi bud, you said you got connected and all you see is a terminal window, i dont know what your complete set up is but here,s mine i hope it helps.

    Be sure your vncserver is running by. . ., vncserver :1 next sudo nano into ~/.vnc/xstartup this brings you to a bin!! bla bla file, where you see the last line, & -x-window-manager ADD THIS & /etc/X11/Xsession &

    Now go into this file, /etc/xrdp/startwm.sh and be SURE IN THERE, your last line is

    . /etc/X11/Xsession after doing so restart the vncserver by doing this.

    vncserver -kill :1 then restart

    vncserver :1

    By the way i had to install more than just the Xrdp and i did a few more commands for a fall back if Xrdp failed, all seems good at the minute for me, give it a go sure and lets know whats cooking or not. Good luck. Ps.. its frecking great when it works, stay with it.

  • K.K Patel

    Welcome to Ubuntu Community.

    First of all Check Network Settings of windows Virtual Machine in Virtual Box. Choose Bridge Connection in Network settings.Check that RDP is allowed to pass through Firewall of Window Client.

  • stevenmirabito

    I'm not familiar with xrdp in particular, but the first thing I'd check is to see if the port its using is a) listening for connections and b) open to the outside world. The default port for RDP is 3389.

    The first is pretty easy to check; simply run this in terminal on the machine you're trying to connect to (change 3389 if xrdp is listening on a different port):

    netstat -an | grep "LISTEN " | grep ":3389"
    

    If you get something similar to the following, something at least (hopefully xrdp) is listening for connections:

    tcp        0      0 127.0.1.1:3389            0.0.0.0:*               LISTEN
    

    If you don't get any output, try (re)starting xrdp or check to make sure you have the right port.

    Next, you need to make sure that the machine is accessible to the Internet on that port, which involved two things: making sure that the firewall on the machine itself isn't blocking connections to that port, and making sure that any network device (i.e. a router) between the computer you're trying to connect to and the Internet isn't blocking connections. PortForward.com can help with the latter; the first depends on what kind of firewall is installed on your machine, if any.

    Hope this helps!

  • hmayag

    I finally got this to work for me; setup: older laptop running ubuntu 13.10 running standard unity; I have installed cairo dock (which makes it much more usable for me); still not used to the left side app bar;

    It would be nice to be able to use my win7 system to rdp into this ubuntu 13.10 so I spent a couple of hours this morning doing research. Here is what I did:

    sudo apt-get update
    sudo apt-get install xrdp
    

    or you could use ubuntu software center to install.

    The installation appeared to go ok and it appeared that the xrdp service was started ok.

    From my win7 box, I opened an rdp window and used the laptop's IP address to get in; a window did open up but just a standard x11 windows screen (cross-hatch pattern with x cursor); no links, icons or menus to use.

    More google research. I installed the gnome-session-fallback:

    $ sudo apt-get install gnome-session-fallback
    $ echo "gnome-session --session=gnome-fallback" > ~/.xsession
    

    This didn't work; I got the same blank screen, but found another URL that suggested another windows session mgr like XFCE, so I installed xubuntu desktop:

    $ sudo apt-get install xubuntu-desktop
    $ echo "xfce4-session" > ~/.xsession
    

    Don't forget to sudo /etc/init.d/xrdp restart after all the changes.

    This worked. At first, on initial start-up of rdp session, I got the same blank screen but after 10 seconds (probably because I am using a win7 VDI at work from a remote location) up popped a usable xfce xubuntu desktop; not as nice as gnome but very usable.

    Hope this info will be useful, as I couldn't get the initial attempts to work for me.

    Dave