login - Why do I keep getting "invalid password" when trying to log in?

20
2014-04
  • Novak

    I have read and tried everything that I can find and I am still having issues logging in. I have Ubuntu 11.10 that I have put on my machine a couple of weeks ago and I still cannot log in. It says invalid password.

    So I have tried to reboot and reset. I have even tried to remount.

    What am I doing wrong? I am a beginner trying to learn and I am not sure why I can not sign in.

  • Answers
  • Eliah Kagan

    You said you've reset the password and the problem still occurs, so presumably the problem isn't that you're entering it incorrectly. A few possible causes come to mind:

    • Maybe you are not using the right keyboard layout when entering your password. You can choose your keyboard layout at the graphical login screen by clicking the keyboard icon in the bar at the top. A drop-down menu will come up, showing the available keyboard layouts. (There might just be one, but if you have more than one set up, you can select between them.)

    • Maybe your password contains unusual characters that are not being handled properly. If your password contains characters other than upper and lower case letters, numbers, and punctuation present on US-English keyboards (~!@#$%^&*()_+-=[]\{}|;':"<>?,./`), try resetting the password again, this time to something limited to those characters. (You don't have to use all those types of characters if you don't want to, though your password should be long or complex enough that it's very hard to guess.)

    • Maybe something is going wrong when you reset your password. If you edit your question to include a detailed description of how you're resetting your password, a link to the procedure you are following to do so, or both, then it may be possible to assess this.

      Furthermore, if it turns out you mean something else by "reset" than resetting your password, then that is very relevant. In that case, you should reset your password using one of these methods or (as suggested by tijybba), this method.


    If you get Authentication token manipulation error when changing your password in recovery mode and you cannot fix it with mount -o remount,rw /, changing the password by chrooting from a live environment will still almost always work. I strongly recommend trying that.


  • Related Question

    login - Ubuntu asks for password several time when logging in
  • Yotam

    When ever I log into my machine (Lenovo Laptop) Ubuntu (Natty running Unity) ask for the keyring password several times (4-5) why does it do that and how can I make it stop?


  • Related Answers
  • Xiao-Long Chen

    That sounds like a problem with the Gnome keyring. I suggest backing up your ~/.gnome2/keyrings directory and then try removing it to see if that helps. Of course, when you reenter your passwords for Evolution or a wireless network, it will ask you to create a password for your newly created keyring (picture shown below). Make sure that password is the same as your login password.

    Keyring

    Also, if you connect to a wireless network and you log in automatically, make sure you select "Available to all users" in your wireless settings.

    enter image description here

  • Caleb

    Probably whatever agent is supposed to be handling storing that is not running in your session and it can't remember from one minute to the next, so each time a program needs authentication it prompts you again. Just a guess.