10.10 - VirtualBox seems to disable printing in Ubuntu to USB Printer

24
2014-04
  • Karlson

    I am running Maverick on my machine and I have Lexmark X6675 connected to the system via USB. I also have VirtualBox 4.1 running Windows Vista on the system. And I have a very interesting situation with Printing.

    If I have VirtualBox running with USB device that is my printer enabled to VirtualBox I am unable to print from Ubuntu. I have to shutdown VirtualBox (I haven't tested but disabling the USB access probably does the same, I'll have to check) and then I can print from Ubuntu.

    Is this normal behavior? Is there a way to configure either VirtualBox or Ubuntu or both so that they can gracefully share the printer?

  • Answers
  • fossfreedom

    If both the virtualbox guest and ubuntu are sharing the same USB connection then you will need to define either the guest or ubuntu to be the "master" printer server.

    For example, you can have two printer connections in ubuntu - one for the local USB printer and the second set to print to the windows guest print server.

    enter image description here

    Thus, when you want to print from ubuntu when the windows guest is running, select the printer connected to the windows guest.

  • bodhi.zazen

    Virtualbox is sort of "funny" that way with usb devices. They can be shared, but typically are available to either the host or guest, but not both at the same time.

    You might be able to continue to share other usb devices, but mark the printer as not shared.

    enter image description here


  • Related Question

    windows xp - print from VirtualBox to networked printer
  • Stann

    I run Ubuntu 10.10 64-bit desktop edition and I have Panasonic networked printer KX - MX2000 printer.

    There are no 64 bit drivers available from Panasonic for Ubuntu/debian. They only have 32 bit drivers for RHEL :( So - there is no way I can print from my computer to that networked printer directly.

    So - my idea was to install printer drivers onto Windows XP VirtualBox guest and just printer from virtual machine.

    I've installed XP drivers onto guest, VirtualBox network adapter set to Bridged, I can see printer in the browser from guest, I can ping printer from guest but when I try to print nothing happens.

    What am I doing wrong. IS there something else I have to configure?

    UPDATE:

    Panasonic Red Hat drivers: http://panasonic.net/pcc/support/fax/common/table/linuxdriver.html

    TO INSTALL THEM ON UBUNTU

    sudo alien --scripts -k libjbig-1.0.0-1.i386.rpm libtetra-1.0.0-2.i386.rpm rastertogdi-1.0.1-9.i386.rpm
    
    sudo dpkg -i libjbig_1.0.0-1_i386.deb libtetra_1.0.0-2_i386.deb rastertogdi_1.0.1-9_i386.deb
    
    sudo service cups restart
    

    now - there will be some errors during execution which shouldn't affect anything.

    BUT THE PROBLEM IS

    I cannot get it to work on Ubuntu Maverick 10.10 64 bits (or any other 64 bits distro for that reason. Only tried on Ubuntu 10.10 64 though.). Any sugguestions guys? :) Thanks


  • Related Answers
  • Martin Owens -doctormo-

    I don't think it's possible to get the 32bit driver installed on 64bit currently. But if you know you have a 32bit requirement it might be worth getting 32bit desktop instead.

    As for virtual box, there is no reason I can think of why it wouldn't work. Try reinstalling the windows drivers and making sure the network is good.