VirtualBox can't find any USB devices on my host. How do I use USB passthrough?

21
2014-04
  • runeks

    I'm running the newest version of VirtualBox, 4.1.18-78361~Ubuntu~precise from the VirtualBox repository, on Ubuntu 12.04 with the Oracle VM VirtualBox Extension Pack.

    When I go into Settings->USB for my virtual machine and click "Add Filter From Device" I get no devices in the list. Only a text saying "no devices available".

    The device I'm trying to use in the Windows 7 x64 guest OS is a SATA-to-USB controller that is present on my Ubuntu system. There is both this device and USB mouse connected to my Ubuntu PC, neither of which show up in VirtualBox (output from lsusb):

    Bus 006 Device 002: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
    Bus 003 Device 002: ID 174c:55aa ASMedia Technology Inc
    

    I've set up a USB device filter on the Settings->USB page for a device with Vendor ID 174c and Product ID 55aa. When I plug in the device, however, a prompt from Ubuntu pops up asking me to enter the password to decrypt the volume (the disk in the SATA-to-USB controller is encrypted using dmcrypt and set up with LUKS).

    My user is a member of vboxusers:

    rune@rune-desktop:~$ groups rune
    rune : rune adm cdrom sudo dip plugdev lpadmin sambashare vboxusers samba
    

    How do I get my Ubuntu 12.04 host OS to pass on the USB device to my Windows 7 guest OS?

    EDIT: Output of ls -lR /dev/vboxusb/ as requested:

    /dev/vboxusb/:
    total 0
    drwxr-x--- 2 root vboxusers 60 Aug 15 21:31 003
    drwxr-x--- 2 root vboxusers 60 Aug 15 21:20 006
    
    /dev/vboxusb/003:
    total 0
    crw-rw---- 1 root vboxusers 189, 257 Aug 15 21:31 002
    
    /dev/vboxusb/006:
    total 0
    crw-rw---- 1 root vboxusers 189, 641 Aug 15 21:20 002
    

    EDIT: Now it works :. I have no idea what I did (if anything) to make it work. But now all the devices show up, and the guest OS can use the device in question correctly.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    Guest OS cannot see USB even after selecting it in VirtualBox
  • Paddy Landau

    I have the latest VirtualBox 4.0.8 (from the VirtualBox website), including the extension pack, running on Ubuntu Lucid 10.04. My user is a member of vboxusers.

    The guest OS is Windows XP (32-bit).

    Everything works -- except the USB. In the USB settings. I have set the default filter (to allow all USB devices). While the guest is running, I go to Devices > USB Devices and select the device (it's a simple USB stick formatted as FAT32).

    Although the device is automatically unmounted from Ubuntu, Windows XP fails to see it (normally XP would have a little dialogue about installing a new device and then show the icon to safely remove a drive. It does not do this).

    Any ideas how to solve this problem, so my guest Windows XP can see the USB stick?


  • Related Answers
  • Seasoned Advice (cooking)

    A bit of Googling told me to look in Control Panel > System > Hardware. I found the USB with a yellow question mark. Right-click > install driver did the job. Thank you. I hope this helps someone with the same problem.

    OP solved issue Comment to answer