kernel - Upgrading to Xubuntu 12.10 using a Non-PEA supported CPU

21
2014-04
  • Michael

    Possible Duplicate:
    Will it be possible to use a non-pae kernel in 12.10

    I have just been upgrading my Xubuntu 12.04 system to Xubuntu 12.10. However I've got several error message during the upgrading process. At the end I was left with two broken packages: linux-image-extra-3.5.0-17-generic and linux-image-generic.

    Trying to reinstall them gives me the following error message:

    This kernel does not support a non-PAE CPU.
    

    I have found the following posts:

    http://www.mail-archive.com/[email protected]/msg3868794.html

    https://lists.ubuntu.com/archives/ubuntu-devel/2012-May/035176.html

    Do I understand them right that my CPU is not supported anymore? Is there any other way to fix this problem?

    Thanks

  • Answers
  • Takkat

    Unfortunately this is true. Lubuntu and Xubuntu 12.04 LTS were the last releases supporting a non-PAE CPU by providing a 32-bit non-pae kernel as can be read from the release notes:

    The i386 images use a non-PAE kernel. The non-PAE kernel will not be available in future Xubuntu releases.

    Therefore it is recommended to stay with the 12.04 long term release on an old system which does not support PAE. This release will be fully supported until end of 2017.

    See also this question:


  • Related Question

    Problem with VirtualBox after enabling 'pae' in 10.04 kernel
  • Peter.O

    I installed the 2.6.32-32-generic-pae kernel over my existing 2.6.32-32-generic kernel.

    This solved the problem I had with the system not showing the full amount of RAM, but it has had a side-effect. I can't start my VirtualBox VMs. I get this message:

    Kernel driver not installed (rc=-1908)
    Please install the virtualbox-ose-dkms package and execute 'modprobe vboxdrv' as root

    virtualbox-ose-dkms was already installed and when I ran sudo modprobe vboxdrv, I got another error message:

    FATAL: Module vboxdrv not found.

    I purged virtualbox-ose-dkms (complete removal) and then re-installed it, but I still got the same error.

    I then repeated the full re-installation, but this time with the previous non-pae kernel. It works, but fails when I reboot into the pae kernel.

    Next I uninstalled and then re-installed VirtualBox into the pae system, but it gave the same error.

    What can I do to get VirtualBox running with the pae kernel?


  • Related Answers
  • Peter.O

    The issue was solved thanks to the comments to the question... VirtualBox is working again... by uninstalling and re-installing things in the correct sequence.. (I've "answered" in this way, as there was no other specific answer...)