drivers - Unable to detect graphics card in 12.04 LTS

20
2014-04
  • Darth Coder

    Hi I just recently installed Ubuntu onto my laptop (Dell Inspiron 15r 5520 64-bit) alongside Windows 8. While Ubuntu 12.04.2 LTS seems to be working fine otherwise, in System Settings it is unable to detect my graphics card and shows as "unknown".

    I tried the following commands and this is what i get:

    $ lspci -v | grep -i vga
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (prog-if 00 [VGA controller])
    

    I have the ATI one as far as I know, so what's with the Intel VGA being displayed??

    Secondly, in System Settings > Additional Hardware I activated the ATI/AMD proprietary FGLRX graphics driver (post-release updates). The thing downloaded and installed itself and but it shows as "The Driver is activated but not currently in use". I don't really know what that means.

    After some digging around, I tried the following commands as well but to no avail:

    sudo apt-get purge fglrx*
    sudo apt-get install fglrx
    sudo aticonfig --initial
    

    Next I went to the AMD site and downloaded the requisite driver from here I followed the steps in their instruction manual, used the following command again:

    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
    

    and then went to the folder where I had download the driver and ran the installation file. I went through the setup process, did:

    /usr/bin/aticonfig
    

    and rebooted my laptop. Still I am stuck at square one, however, my Hardware info now shows the ATI VGA driver in addition to an Intel one. Here are the names:

    -PCI Devices-

    VGA compatible controller : Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])

    VGA compatible controller : Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (prog-if 00 [VGA controller])

    Snapshot of PCI Devices

    After I installed the downloaded ATI driver and checked System Settings > Additional Drivers, I see that the Raedon VGAs have been deactivated again, as shown: enter image description here

    Here is a link to the /var/log/Xorg.0.log. Hope all this info helps.

    Please help me detect my graphics card, I need it for dozens of applications specially Compiz effects, games etc. I am a novice so kindly explain your answers as far as possible so that I can make the best of of them. Thanks in advance :)

  • Answers
  • soulsource

    The display of the graphics card name in System Settings often does not work (just search askubuntu, there are dozens of questions about it and the answer is always the same...). I wouldn't worry about it and only trust other tools to find out which graphics driver is in use.

    Your laptop obviously has a recent Intel CPU, which includes a graphics unit. This is the reason, an Intel graphics card is shown in lspci.

    Your xorg.conf hints that atm you are using fglrx, and it seems to be working. To see, if the driver is really active, simply try to run fglrxinfo. Another tool that you might take a look at is amdcccle, the catalyst control center. It will give you a lot of details (if fglrx is installed).

    Since you installed the driver from the AMD website, "additional drivers" will not show any driver in its list as active (since you didn't use official driver packages for Ubuntu, but the download from the AMD website).

    I don't know about your laptop specifically, but you might find this guide useful: Installing Catalyst with Intel/AMD hybrid graphics

    Oh, and btw, the preferred way to install the driver downloaded from the AMD website would be to make distribution specific packages and then to install those. By this, you can ensure that it stays working when you get Kernel updates. If you simply install it, it might be, that you have to reinstall it every time, a Kernel update is installed.


  • Related Question

    Hybrid graphics driver not working (12.04)
  • Marco Sacristão

    After two days of intensive research and two Ubuntu 12.04 and 12.10 installations later I've reached a dead end.

    I currently own a HP dv6-3315ep laptop, which comes with a 6550M graphics card, and the Intel graphics card for lower power consumption (switch-able graphics).

    I've read everywhere how to install the AMD drivers manually, which I've done in all different ways, including different versions due to the how-to posts being dated and new driver versions being available, and also tried installing the drivers to the additional drivers directly from Ubuntu, with that being said I've either ended in Low Graphics (after running aticonfig --initial -f) mode or using the default drivers from the clean install (because not forcing aticonfig --inital would come out as not detecting anything related to any usable AMD hardware).

    Before installing fglrx, I've lspci | grep VGA and what I've got from it was

    00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series]

    what made me realize that it would seem like it was not detecting my graphics card correctly, but I didn't mind it.

    So, I wish to know if there is any reliable method that I could use to correctly install AMD proprietary drivers on my computer, or only install the Intel graphics driver so it would allow me to use the HDMI and VGA ports on my computer.

    Thank you for reading.


  • Related Answers
  • aximab

    If I am right this is a muxed hybrid system. In my opinion; here is the problem : 1) The "recent" catalyst driver don't support muxed system... 2) The "old but not to old "catalyst driver support muxed graphics system but not recent kernel nor Xorg server. It cause the installation to failed. And Unfortunately I was not able to determine precisely the driver version for which it support muxed system.

    So a further investigation would be : -Find the version for which muxed system was supported. -Then find a combinaison of Kernel/xorg ( hopefully jut a good version of unbuntu) compatible with this driver. Personnally, I gave up since I want to use recent kernel/xorg.... The starting point is wiki.cchtml.com but it didn't led me too far.