Ubuntu won't boot after 12.04 upgrade

24
2014-04
  • u60757

    I installed Ubuntu 11.10 a few weeks ago and yesterday I upgraded it to 12.04. The upgrade manager installed all packages and then asked me to reboot my computer. Everything went well, I was able to use it without any problem.

    Today I turned it on and here is my problem: it won't boot anymore. When it gets to the login screen it freezes.

    • I tried opening a terminal with Ctrl+Alt+F1 but it wouln't open.
    • I rebooted and tried booting with a older kernel version but it didn't work.
    • Then I booted from the recovery and tried to fix it but I couldn't.

    When I was at the recovery menu I tried to activate the network option, but the network-manager failed and the system freezed. I think that may be the problem, but I don't know how to fix it. Thank you for your help.

  • Answers
  • Sun Dial

    Make a CD of Super Grub Boot disc; it will find all the OSs and allow you to choose and boot. Also try 'Try Ubuntu' from the Live CD, and install into it Grub Customizer. Launch that and you may be able to adjust the settings to get back to booting normally. Super Grub disc has got me out of trouble many times. Good luck


  • Related Question

    Ubuntu won't boot after upgrade to 11.10
  • Dave M G

    I have just upgraded one of my computers from 11.04 to 11.10 using the upgrade tool in the update manager interface.

    Everything seemed to go smoothly, until the very end when the reboot happened. At that point, it would not reboot.

    When I reboot, one of three things happens. It hangs at a blank purple screen, it hangs at the screen with the Ubuntu logo and five orange dots underneath, or, if I try to boot into recovery mode, it blurts out some text. Here is what those screens look like:

    bad boot screens

    Here is a close up of the text from the screen I get when going into recovery mode. It is always the same. The black text over top the option interface seems to prevent me interacting with it, so this is how it stays unless I reboot:

    bad boot text

    I can't seem to initiate any way of getting to a prompt. [CTRL]+[F6] or [CTRL]+[BACKSPACE] don't work. I tried pressing [F6] immediately after GRUB finished, which I thought I read on the net somewhere would help... anyway, I don't know how to initiate any kind of interface so I can even figure out what the problem is.

    The usual suspects are the Nvidia graphics card, or maybe something to do with my software RAID (2 500GB drives). However, I have no idea what is actually happening.

    How do I get my Ubuntu 11.10 to boot?

    (Previous versions seem to have been removed, so I can't go back.)


  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.