sound - Ubuntu 13.04 bluetooth A2DP does not work

20
2014-04
  • user153241

    I have installed Ubuntu 13.04 in a new partition and I have some issues with bluetooth.

    I usually use bluetooth to connect to my wireless headset, in the old partition with Ubuntu 12.10 everything is okay.

    Ubuntu is able to detect my bluetooth receivers but I can't pair my device. After googling I found that all I need is to add Enable=Socket in the general section of /etc/bluetooth/audio.conf.

    After restarting the bluetooth daemon I am able to pair my wireless A2DP receiver and I see the bluetooth adapter under the audio setting, that means that pulseaudio has recognized my A2DP adapter.

    Unfortunately when I play the audio file, I hear the output through the PC speakers rather that my bluetooth handcuffs.

    Any idea how to resolve this?

    I tried formatting and reinstalling Ubuntu 64-bit from scratch in order to get a clean install but the problem is still there. I suspect the Ubuntu team has changed something in the bluetooth settings from 12.10 to 13.04.

  • Answers
  • Biblioclasta

    This worked for me:

    1) Open /etc/bluetooth/audio.conf

    gksudo gedit /etc/bluetooth/audio.conf
    

    2) find "Enable =..." under [General] and delete Socket fron the list

    [General]
    Enable = ....
    

    3) Add this line:

    Disable = Socket
    

    4) Save

    5) Restart the bluetooth service

    sudo service bluetooth restart
    

    6) Restar pulseaudio for good measure.

    pulseaudio -k 
    pulseaudio -D
    

    7) Cross Your Fingers and try.

  • user165648

    I'm running ubuntu 13.04 and had a simlar issue after upgrading from 12.10, I've managed to temporarily get around it, but unfortunately this needs to be redone after each reboot. If anybody can automate this process please let me know how. Thanks.

    First we need to kill pulseaudio, -- but pulseaudio always restarts, so we need to disable that - Into terminal; sudo gedit /etc/pulse/client.conf

    change "autospawn = yes" to "autospawn = no", and set "daemon-binary" to "/bin/true". Make sure these lines are uncommented.

    save, and close the file. Done, pulse audio will no longer restart after a crash or force close.

    Next run, sudo gedit /etc/bluetooth/audio.conf

    and under 'General' add Enable=Socket

    close and save the file.

    run in terminal; sudo service bluetooth restart

    run in terminal; pulseaudio --kill

    now connect to the bluetooth device (I've tested this using BLUEMAN)

    run in terminal; pulseaudio

    then in a different terminal window; sudo gedit /etc/bluetooth/audio.conf

    remove "Socket", leaving "Enable="

    save and close the file

    run in terminal; sudo service bluetooth restart

    connect to your bluetooth device again; - and it should (hopefully) work.

  • MarkMe

    I had the same problems after upgrading from 12.10. After removing all configuration files from my home directory and reinstalling from scratch bluetooth ad2p was working again. Not the most ideal solution, but it worked.

  • Springinjecter

    I had the same problem. My problem was, that avahidaemon crashed.

    1. sudo service avahi-daemon start #start avahi
    2. sudo service bluetooth restart #restart bluetooth to connect to avahi again
    3. sudo pactl list cards short #get name auf bluetooth-card
    4. sudo pactl set-card-profile <> a2dp #For me sudo pactl set-card-profile bluez_card.00_1E_7C_01_6D_45 a2dp

    Hope this helps.

    regards Anton


  • Related Question

    sound - Bluetooth audio stops working after some random time
  • Kunal

    I am using Ubuntu 11.04 and want to use my new Nokia BH-503 Bluetooth headsets with Ubuntu to watch movies and listen songs. I can pair my headsets using a Bluetooth dongle, and even see it in sound preferences and by setting it as default, I can use them with movie player and rythmbox player.

    However, after some random time, the audio just stops. It doesn't come up until I switch to different default device in sound preferences or disconnect my Bluetooth dongle and reconnect all again.

    Please help me fix this Issue. I tried with totem movie player and VLC. Same issue persists.


  • Related Answers
  • Allan

    It sounds like you maybe being affected by this bug #455998 I'm not 100% sure but the fix proposed isn't dangerous

    the fix is to remove the ./pulse folder from your Home folder this folder is generated by pulse audio each time you login to your system to add any new hardware or removal of etc.

    you can do this in two ways open your home folder press ctrl+H to show hidden files and folders then select and delete the ./pulse folder alternatively you can use this command in terminal

    rm -r ~/.pulse* then reboot and after logging in open a terminal and run alsamixer and make sure none of the audio outputs are muted as its a bluetooth device you should have the device connected while running alsamixer.

    Hope this solves your problem.

  • Daniel

    Your answer may be addressed in this post below. Looks like pulseaudio has a switch which attempts to suspend sinks that are inactive for periods of time, and perhaps it doesn't do such a good job of "unsuspending" when the sink is a bluetooth device. I've tested it and it's fixed the problem with my P311's in Natty.

    http://robert.orzanna.de/2011/08/10/prevent-idle-suspend-with-a-bluetooth-headset-and-a2dp/