wireless - Ubuntu 12.04 Wifi issues Macbook 7,1

19
2014-04
  • Phil

    Ok, so I have a Macbook Pro 7,1 (mid 2010) installed. I installed it a few months back and had A LOT of problems trying to get the wireless to work. After much searching I found a solution, I believe I manually downloaded the correct drivers from somewhere and installed them with terminal...something along those lines finally got it working.

    Now due to issues with other partitions(windows)/rEFIt I decided to start fresh and completely reinstall Ubuntu as well. Now I'm in the same place again...struggling to get my wireless to work. I've tried tons of solutions with no luck and can't find the solution I used last time. Any help would be much appreciated.

    Some solutions I attempted include: -purging and reinstalling the drivers through terminal -using additional hardware (broadcom fails) -using the synaptic package manager -installing and blacklisting

    Thanks!!

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    11.04 - 12.04 & 11.10 macbook pro issues. Trackpad and Mouse aren't working. Can't login or boot from cd
  • user60420

    I just updated my macbook to 12.04 LTS and upon install my wi-fi wasn't working or even showing up for that matter. I then downgraded to 11.10 via booting from an install disc. Upon downgrading to 11.10 I had the wifi problem yet again, along with my mouse not working. ( a USB one helped me )

    I then restarted the system and wifi and the mouse problems were temporarily fixed. I then installed a few sources & apple drivers via terminal. I rebooted so these could take effect and my computer now won't respond to mouse or even keyboard actions. Even when plugging in a USB mouse or keyboard nothing works.

    I can't boot from CD holding C at startup, and can't get into the boot options with shift either. I also have tried Control Alt F1 with no luck.

    Any feedback would be greatly appreciated.

    Thanks!


  • Related Answers
  • bubby

    I had the same problem when booting from CD. Then I got it solved by holding the "option/alt" key and it shows whether to boot from CD. Hope it helps. CD was showing up as windows cd for me eventhough it was Linux Mint CD.