networking - Ubuntu 12.04 - USB3 issue with mobile broadband usb sticks

24
2014-04
  • Madvinegar

    I am getting a very strange problem as regards the USB3 port of my laptop under ubuntu 12.04 (My laptop is a Dell Inspiron n14z). The laptop has two USB3 ports and one USB2 port.

    In order to get any usb mobile broadband stick(s) to work, I have to plug them in the USB2 port. They are immediately recognised and I can connect. If I plug them in one of the two usb3 ports, they are not recognized.

    I even get different results from lsusb. I have tried this with four different USB sticks. One of O2, one of vodaphone, one of WindHellas, and one of CosmoteHellas. Three of them are Huawei and one of them is a K3570-Z.

    As an example of a huawei e173:

    lsusb result when plugged in USB2:

    Bus 002 Device 005: ID 12d1:1436 Huawei Technologies Co., Ltd.
    

    lsusb result when plugged in USB3:

    Bus 003 Device 003: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800 (HSPA modem)
    

    I don't think that this problem has anything to do with the laptop brand or the mobile broadband usb sticks. The reason for that is that on the same laptop the usb sticks work just fine on all usb ports when I am running windows 7 or ubuntu 11.04. So this must be somekind of a bug relating to ubuntu 12.04. Is anyone else experiencing the same problem? I thank you very much in advance for any of your thoughts/ideas/assistance.

  • Answers
  • Martin Owens -doctormo-

    This makes sense. Each USB device type gives a unique ID to the computer so the computer can load the correct driver. If you use a different ID for USB3 then you end up confusing a driver which has a list of ids which this new id isn't in.

    To fix the issue permanently, the driver must be modified to include the new IDs. This is a problem with Linux (kernel) and should be reported as a bug.

    To get it working for yourself, you can follow this guide for adding an id to your driver: http://www.ha19.no/usb/ Attempt this only if you're comfortable running the commands.


  • Related Question

    USB Mobile Broadbands on UBUNTU 11.10
  • CME64

    this is really a weird problem,

    it seems that mobile broadbands can be recognized only by the live/live-install version on the usb/cd but cannot be recognized on the installed system !

    I tested it on 2 different computers "Laptops" (HP/ASUS) with 2 different usb broadbands (huawei/alcatel)

    details :

    no broadband connection type is detected even with manually adding connections

    no problems on the live version (iso --> USB) !

    system : Ubuntu 11.10 X64amd just installed currently

    * Laptop1: ASUS F8SN, cpu : intel core 2due 2.4ghz T8300 penryn SantaRosa USB:2.0 VGA:NVIDIA 9500m GS Motherboard : Asus F8000 , Intel chipset , Intel BUS

    * laptop2: HP Pavilion DV 2550 Special Ed, CPU:1.5 core 2due, USB:2.0 Motherboard: Intel

    • USB Mobile Broadband 1 : Huawei, Vid/Pid : 12D1 / 140C .. this one worked on both computers so far but not always, mostly it is not recognized
    • USB Mobile Broadband 2: Alcatel, model : X060S .. this one never worked on both computers "except on live boot (usb/cd) both broadbands are always recognized" how strange is that !

    it seems (from internet search) that this problem is common to all broadband users with no complete solution and it must be solved permanently


  • Related Answers
  • Lekensteyn

    Installing Mobile Broadband in Ubuntu 11.10 (Oneiric Ocelot)

    1. Make sure that you've refreshed your software sources. You will need to connect your computer with Internet Modem using wire. Then run the next terminal command:

      sudo apt-get update
      
    2. Open the Search panel from the Ubuntu icon present in top of the launcher.

    3. Search for the Additional Driver in the search box, this will open a new window from there you just select “Broadcom STA wireless Driver” and click on Add.
    4. Wait for some time until the installation gets complete.
    5. You need to restart your system to activate and complete the installation.
    6. Now go to the network connection icon present at the top panel and select your network name.
    7. Enter the password and click on Connect. This will establish the wireless connection or mobile connection.