10.04 - This flash plugin was blocked because it is out of date

24
2014-04
  • Registered User

    I being a developer want to use Flash version 10.1 or older on some of my Ubuntu machines. The problem is each time I run Google Chrome on this Lucid 64 bit machine (which is the only machine with me) I get a warning:

    This flash plugin was blocked because it is out of date

    As per instructions on these links:

    then I tried at a command line:

    google-chrome --allow-outdated-plugins
    

    But I still got the same warning. Is there a way I can use with an old version of flash plugin?

    UPDATE 1
    As per below suggestion I edited the hex value of one of the file /usr/lib/firefox/plugins/flashplugin-alternative.so /usr/lib/iceape/plugins/flashplugin-alternative.so /usr/lib/libvisual-0.4/morph/morph_flash.so /usr/lib/openoffice/basis3.2/program/libflashlx.so /usr/lib/xulrunner/plugins/flashplugin-alternative.so /usr/lib/flashplugin-installer/libflashplayer.so /usr/lib/midbrowser/plugins/flashplugin-alternative.so /usr/lib/xulrunner-addons/plugins/flashplugin-alternative.so /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/iceweasel/plugins/flashplugin-alternative.so /usr/share/ubufox/plugins/npwrapper.libflashplayer.so /var/lib/flashplugin-installer/npwrapper.libflashplayer.so

    which was
    /usr/lib/flashplugin-installer/libflashplayer.so
    From 10.1 to 10.2 but there was no effect.How do I find out which file is google-chrome using from above?

    UPDATE 2 Following from lsof output I found

    var/lib/flashplugin-installer/npwrapper.libflashplayer.so
    

    is the flash plugin which google chrome is using and there I could not find the string Flash 10.1 as mentioned in reply below.

  • Answers
  • Jorge Castro

    Google Chrome will always block older versions of Flash. I think you might be better off either using another browser or an updated version of flash, because Chrome is not going to play nicely with old flash no matter what you do.

  • Ramón

    If Roland is right and there is no way to disable this warning in some official way, then maybe you can give this a shot (I just tried the reverse, changing 10.2 to 10.1 and Chrome now blocks Flash by default with the warning):

    Install a hex editor like ghex

    sudo aptitude install ghex

    From a terminal, enter the chrome directory.

    cd /opt/google/chrome

    Make a backup copy of the flash player library in your home directory.

    cp libgcflashplayer.so ~/.

    Open the library in ghex and search for "Flash 10.1" (type in the right pane of the search dialogue).

    sudo ghex2 libgcflashplayer.so

    enter image description here

    Close the search window and modify the version number from 10.1 to 10.2. Save your changes. Any tab with Flash running will crash at this point. Restart Chrome and test your change. With luck it will work.

    Now note, I imagine this will also affect anything else that checks what version of Flash you are running so keep that in mind for whatever tests you are doing.

  • type

    Chrome seemed to use an outdated version located in /usr/lib/mozilla/plugins, so finally this works for me:

    sudo rm /usr/lib/mozilla/plugins/libflashplayer.so

    sudo apt-get install adobe-flash-properties-gtk adobe-flashplugin

  • SharkyXTS

    I downloaded the .tar.gz package from the Adobe website and copied libflashplayer.so in /usr/lib/mozilla/plugins to solve this issue.

  • Eugene van der Merwe

    I started having this problem with Ubuntu 11.10.

    I read every single reply here but none worked. Eventually I browsed /opt/google/chrome/plugins and found three outdated files there. The three outdated files were:

    libflashplayer.so Nov 2 2010

    libflashplayer.so.64bit Jul 23 2009

    libflashplayer.so.org Nov 14 2008

    I created a folder called: /opt/google/chrome/plugins/backup and move all three files there.

    I then went to http://get.adobe.com/flashplayer/ and downloaded the .tar.gz for other Linux.

    I extracted the file libflashplayer.so to /opt/google/chrome/plugins and finally after months of frustration the problem is sorted out.


  • Related Question

    10.10 - Flash is not working in Chrome (Crossover Linux is installed)
  • Jim Ford

    I have google Chrome 8.0.552.237 on Ubuntu 10.10 64-bit and flash is not working, I have tried a variety of methods to install flash, including Firefox flash-aid and the flash-installer package and nothing is working for me. I have even uninstalled and reinstalled chrome to no avail.

    I get "missing plugin" message where flash plugin should be in a website.

    What am I missing?

    I have a variety of plugins returned by jgbelacqua's command:

    /usr/lib/chromium-browser/plugins/flashplugin-alternative.so
    /usr/lib/firefox/plugins/flashplugin-alternative.so
    /usr/lib/flashplugin-installer/libflashplayer.so
    /usr/lib/iceape/plugins/flashplugin-alternative.so
    /usr/lib/iceweasel/plugins/flashplugin-alternative.so
    /usr/lib/midbrowser/plugins/flashplugin-alternative.so
    /usr/lib/mozilla/plugins/flashplugin-alternative.so
    /usr/lib/xulrunner/plugins/flashplugin-alternative.so
    /usr/lib/xulrunner-addons/plugins/flashplugin-alternative.so
    /usr/share/ubufox/plugins/libflashplayer.so
    /var/cache/flashplugin-installer/libflashplayer.so
    

    I'm not sure which is necessary and which not.

    I should note tho that my Chromium does have flash and it does work... just not chrome or firefox.


  • Related Answers
  • dv3500ea

    ok Crossover linux added a second flash plugin through wine for chromium / chrome, to turn off the second plugin do the following:

       1. load chrome
       2. hit the wrench button
       3. select preferences
       4. go to Under the Hood tab
       5. under Privacy section hit Content Settings button
       6. select Features -> Plug-ins
       7. push Disable individual plug-ins
       8. In the upper right hit the + next to Details
       9. Scroll down until you see Shockwave Flash
      10. disable all entries other than /usr/lib/mozilla/plugins/libflashplayer.so 
         (or the specific flash version you installed).
    

    Reference Source: http://www.google.com/support/chrome/bin/answer.py?hl=en&answer=108086

    A second option would be to uninstall flash from your crossover bottles. For me this fixed flash in Firefox as well.

  • Lekensteyn

    Try the beta version (9.0). I'm using Kubuntu 10.10 64bits, and Flash works perfectly.

    You can get this version from the the chromium-daily PPA:

    sudo apt-add-repository ppa:chromium-daily/beta
    sudo apt-get update && apt-get upgrade
    

    Note: if you've previously installed the chromium-browser-l10n package for a multi-language browser, you have to uninstall it. This package is not included with the beta package, so you're stuck with an English interface.

  • hexafraction

    Purge (completely remove) and reinstall flashplugin-nonfree with sudo apt-get purge flashplugin-nonfree followed by sudo apt-get install flashplugin-free . This downloads a new version of Flash player complete with new updates, etc. automatically. No reboot needed.

  • Mateo

    It installs Flash for FF. Restart Chrome and it works.... I read about these kind of solutions before. When you cannot install in Chrome try installing in FF..... With thanks to Wizard1000

  • jwernerny

    After fighting flash problems on a couple of different Ubuntu installs, I came across a pointer to a FireFox add-in called Flash-Aid. It is specific to Ubuntu, and it works to try to find the best Flash plugin for your setup. Even though I prefer to run Chrome instead of FireFox, this little tool was able to solve my problems.