12.04 - Slow write speeds to ntfs

16
2014-04
  • hamhut1066

    When writing to my ntfs partition I am getting very low speeds( When reading however I'm getting my maximum speeds):

    589824   3%   60.20kB/s    0:04:06
    

    This example is using

    rsync --progress [File] [Destination]
    

    Where I am making a copy of the file in the same directory.

    I am mounting my ntfs partition using fstab:

    /dev/sda6 /mnt/data ntfs-3guid=1000,gid=11000,umask=0022,sync,auto,nosuid,rw,nouser 0 0
    

    I am not sure if this is relevant but I was recently looking at the Power Tweaking tips provided on the Ubuntu wiki and I believe that these situations may correlate.

    Grub Conf:

    GRUB_BACKGROUND=/boot/grub/gbackground.jpg
    GRUB_SAVEDEFAULT=true
    GRUB_DEFAULT=0
    

    The power tweak that I believe is causing the problem is the ALPM.

    Note: My write speeds to my ntfs patition were absolutely fine until about yesterday when I started fiddling with the power tweak(s)

    I am using one drive with multiple partitions, so it cannot be a hardware error, this is also because My dual boot in windows can access the drive at normal speeds.

  • Answers
  • Akshit Baunthiyal

    Happened to me once. I had edited the fstab to automount the NTFS partition automatically at boot. Restoring the file to before editing it did the trick.


  • Related Question

    11.10 - How do I enable NTFS write support?
  • Hanynowsky

    The NTFS Write capabilities were removed in Ubuntu 11.10.
    Henceforth, I cannot write/delete on my External NTFS hard drive, neither can I on the NTFS partition hosting MS Windows.

    I tried to install NTFS-config (and adding the command sudo mkdir -p /etc/hal/fdi/policy to make it work) but before installing it, it asks for removing these packages to resolve dependencies, so what the heck?
    Is there any other way to write on NTFS partitions in Ubuntu 11.10? Which can be installed smoothly.

    Remove the following packages:                       
    1)       flashplugin-downloader                             
    2)       flashplugin-installer                              
    3)       libasound2                                         
    4)       libasound2-plugins                                 
    5)       libasyncns0                                        
    6)       libatk1.0-0                                        
    7)       libaudio2                                          
    8)       libavahi-client3                                   
    9)       libavahi-common3                                   
    10)      libc6                                              
    11)      libcairo2                                          
    12)      libcomerr2                                         
    13)      libcups2                                           
    14)      libcurl3                                           
    15)      libdatrie1                                         
    16)      libdb5.1                                           
    17)      libdbus-1-3                                        
    18)      libdbusmenu-qt2                                    
    19)      libexpat1                                          
    20)      libffi6                                            
    21)      libflac8                                           
    22)      libfontconfig1                                     
    23)      libfreetype6                                       
    24)      libgcc1                                            
    25)      libgcrypt11                                        
    26)      libgdk-pixbuf2.0-0                                 
    27)      libglib2.0-0                                       
    28)      libgnutls26                                        
    29)      libgpg-error0                                      
    30)      libgssapi-krb5-2                                   
    31)      libgtk2.0-0                                        
    32)      libice6                                            
    33)      libidn11                                           
    34)      libjack-jackd2-0                                   
    35)      libjasper1                                         
    36)      libjpeg62                                          
    37)      libjson0                                           
    38)      libk5crypto3                                       
    39)      libkeyutils1                                       
    40)      libkrb5-3                                          
    41)      libkrb5support0                                    
    42)      liblcms1                                           
    43)      libldap-2.4-2                                      
    44)      libmng1                                            
    45)      libnspr4                                           
    46)      libnspr4-0d                                        
    47)      libnss3                                            
    48)      libnss3-1d                                         
    49)      libogg0                                            
    50)      libpango1.0-0                                      
    51)      libpcre3                                           
    52)      libpixman-1-0                                      
    53)      libpng12-0                                         
    54)      libpulse0                                          
    55)      libqt4-dbus                                        
    56)      libqt4-declarative                                 
    57)      libqt4-network                                     
    58)      libqt4-script                                      
    59)      libqt4-sql                                         
    60)      libqt4-xml                                         
    61)      libqt4-xmlpatterns                                 
    62)      libqtcore4                                         
    63)      libqtgui4                                          
    64)      librtmp0                                           
    65)      libsamplerate0                                     
    66)      libsasl2-2                                         
    67)      libsasl2-modules                                   
    68)      libselinux1                                        
    69)      libsm6                                             
    70)      libsndfile1                                        
    71)      libspeexdsp1                                       
    72)      libsqlite3-0                                       
    73)      libssl1.0.0                                        
    74)      libstdc++6                                         
    75)      libtasn1-3                                         
    76)      libthai0                                           
    77)      libtiff4                                           
    78)      libuuid1                                           
    79)      libvorbis0a                                        
    80)      libvorbisenc2                                      
    81)      libwrap0                                           
    82)      libx11-6                                           
    83)      libxau6                                            
    84)      libxcb-render0                                     
    85)      libxcb-shm0                                        
    86)      libxcb1                                            
    87)      libxcomposite1                                     
    88)      libxcursor1                                        
    89)      libxdamage1                                        
    90)      libxdmcp6                                          
    91)      libxext6                                           
    92)      libxfixes3                                         
    93)      libxft2                                            
    94)      libxi6                                             
    95)      libxinerama1                                       
    96)      libxrandr2                                         
    97)      libxrender1                                        
    98)      libxss1                                            
    99)      libxt6                                             
    100)     libxv1                                             
    101)     nspluginviewer                                     
    102)     nspluginwrapper                                    
    103)     skype                                              
    104)     sni-qt                                             
    105)     zlib1g
    

    Thanks in advance


  • Related Answers
  • enzotib

    You need ntfs-3g to mount ntfs devices. That said, ntfs-config is only needed to configure ntfs in fstab wich I had problems with in the last upgrade. So install the first one and edit the fstab manually. A normal line to mount a ntfs disk in the boot will look like this in /etc/fstab:

    /dev/sda4 /media/windows ntfs-3g defaults,locale=ca_ES.UTF-8 0 0
    

    Where

    • sda4 is the ntfs partition (the number might change in your case),
    • /media/windows is the directory where you want it mounted (must be created manually) and
    • locale must be your language (mine is catalan) because the system uses for reading the names of files and folders.

    In your case i asume must be en_GB or en_US if you're english.

    If you skip the fstab edit you can still use the ntfs partition as a user, just mount it by clicking in nautilus. But it will be mounted as user. With the fstab it's mounted by the system itself (with read/write to all so you can store your data, of course).

    Wish it helps, good luck!

  • Bruno Pereira

    There is simple way to enable NTFS-write by default: - first install the ntfs configs using terminal command:

    sudo apt-get install ntfs-config
    

    if apt not work try using aptitude

    • then you just do this command to enable ntfs-config by default

      sudo mkdir -p /etc/hal/fdi/policy
      

    and last, try to mount the ntfs drive and paste some file to it from the ubuntu and the write function is usable now.

  • Rauls

    It is easier just to install ntfs-3g (it will remove ntfs-progs) and you will r/w support for ntfs drives. I had the same issue and it worked for me.