Problem with pulseaudio, Skype and sound output

20
2014-04
  • Ash Mafiaboy SysemaicallyAffec

    I have Ubuntu 12.04 installed. The problem comes with the sound driver.

    When my Ubuntu is restarted, its seem that the driver is being disabled. The other problem is that when my microphone and sound is working fine on Skype, and when I am trying to play some music on my computer specially when I am on video call we can hear any sound out. Even when I play a song from YouTube I have to sign off from YouTube then, it works.

    I got a 5.1 surround and I wonder if somebody can help me out.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    virtualbox - No sound after PulseAudio reinstall
  • rumtscho

    I encountered an audio bug and reported it on Launchpad. There I was asked to reinstall PulseAudio.

    That sounded dangerous, so I tried it on a VirtualBox virtual machine I had lying around. (this VM had no sound problems at all). And indeed, after I did a naive sudo apt-get remove pulseaudio -> reboot -> sudo apt-get install pulseaudio, the VM has no sound any more.

    Strangely, everything looks OK. There is nothing muted (I unmuted every single playback chanel in alsamixer just in case). The driver for the sound card is recognized and loaded, aplay plays sound files without producing an error, and when I installed and opened PulseAudio Volume Meter, playing a sound resulted in the volume indicator changing with the sound. Only there is nothing coming out of the loudspeakers. This isn't a hardware problem either, because the sound in the host system is functioning.

    I tried to configure PulseAudio as described on this page of the Ubuntu wiki, but had no success.

    I am afraid to try the reinstall on my real system until I know how to do it without causing a problem. Did I miss a configuration step somewhere? Should I have reinstalled in some other way?

    Both guest and host systems are Ubuntu 10.10 64 bit.


  • Related Answers
  • Daniel T Chen

    Please amend your question to include the most current information from pactl stat in a Terminal and from the instructions at https://wiki.ubuntu.com/Audio/AlsaInfo. As an aside, I've contacted Fabio (the person who asked you to reinstall pulse) with clarifications to his triaging process. Thanks for your patience.

  • Takkat

    Try to delete ~/.pulse/ in your home directory where there may rest some erroneous per-user settings. Don't worry it will immediately be rewritten with default settings when the PA daemon restarts.

    To both, check if pulseaudio is running at all, and to start it manually if not type

    pulseaudio
    

    in a terminal. You will get an error if PulseAudio is already there.

    For your bug you may want to check if settings in your /ect/pulse/daemon.conf are o.k., especially look for the entry:

    flat-volumes = no
    

    If this entry is set to yes (by default) PA will always try to output at maximum level. For detail see the PulseAudio Daemon manpage

  • Nyamiou The Galeanthrope

    Go here : http://ubuntuforums.org/showthread.php?t=789578

    Do Part A only. That should fix the problem in no time.

  • rumtscho

    Thank you all for the ideas.

    It must have been a problem in the communication between host and Virtual Box. In the virtual machine settings, I set the sound mode from "Pulse Audio" to "Alsa" and I got sound. Then I toggled it back to Pulse Audio - and the VM still had sound.

    Sometimes the answer is so easy I want to chew on something---