No Sound Ubuntu 12.04 LTS

20
2014-04
  • Roger Harrison

    Toshiba Satellite LD355 S7817 Intel 82801H. Have low volume earphone, no sound from external speakers.

    https://wiki.ubuntu.com/Audio/UpgradingAlsa says

    Sometimes upgrading sound drivers will help you fix an issue with your sound. There are several ways to upgrade your ALSA sound drivers.

    First, some words of caution:

    Warning /!\ Make sure you only have one override of ALSA drivers installed at a time. Make sure you uninstall the previous override before trying a new one, otherwise it is unclear which version will take precedence.


    How to "have one override", and how to "uninstall previous override" ? I'd like to take these precautions before I (a newbie) installs per this ask.ubuntu website. Apparently, my ALSA drivers outdated.

    Thnx ! .

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    No Sound on Ubuntu 12.04
  • Denni

    After I installed Ubuntu 12.04, there are no sound at all on my headphone (rear jack panel).

    On Sound settings > playback, it seemed that the sounds were detected after I choose 'play sound'.

    Anybody can fix this issue??

    Thanks.


  • Related Answers
  • Jorge Castro

    https://help.ubuntu.com/community/SoundTroubleshootingProcedure

    I just did Step 1 and then reboot my laptop and the sound works.

    Transcription if the link does not work

    If you are using Ubuntu 12.04, then execute this command and reboot:

    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
    

    Introduce the whole paragraph in your terminal and it should work. I hope it helps you. For new users, the terminal will run a whole load of commands, do not worry! it will work (well it did for me).

  • Peachy

    Try this:

    sudo killall pulseaudio
    sudo alsa force-reload
    
  • Xiè Jìléi

    Have you been muted? For pulseaudio, try pavucontrol, and check if the mute button is on in the Output Devices tab:

    mute pic

  • Eliah Kagan

    Whatever you do don't enter the huge code on the first answer! It completely ruined my login screen.

    Just use killall pulseaudio in the terminal.

  • Eliah Kagan

    I had the same issue, I ended up plugging my speakers into the rear audio out and it worked. On the sound test under "stereo mode" the front left/right works, but when I put it in 5.1, my speakers are converted to the rear channels like they are supposed to be. So I just leave it in stereo (that's what they are anyways).

    Although, if you have a laptop or "non-HD audio" hardware (only a line in, line out, mic), this won't be possible.

    Also, the strange thing was my front panel audio works fine, must be something goofy with the Realtek HD audio drivers...

  • Bill Todd

    I was having the same issue as the OP for a little while and I finally figured it out.

    Check your BIOS and make sure that your onboard audio is set to Enabled. Not Auto or Disabled. Mine was on auto and nothing would make 12.04 see the device.

  • Akshat Kedia

    This is what fixed it for me.

    Open terminal

    sudo gedit /etc/modprobe.d/modprobe.conf
    

    A new file will be opened, write a line below then save.

    options snd_hda_intel model=mb5
    

    Close file Reboot the computer.

    Thanks to No sound on an iMac

  • Tom Sucic

    This did not work for my case Ubuntu AMD 64 12.04 with HP quad core PC 5GB ram. Other issues existed and sound disappeared after updates and other software install. May have had a script bug as well? Located odd files and delited from home page. found that Kubuntu driver for the PC using the DVD ISO was NVidea MCP61 used sudo apt-get install Nvidea MCP61

    Located synaptic files that were broken and tried to fix them. Un installed or removed one, installed another, updated the third file.

    Turned of PC and restarted after waiting for updates and upgrades to install. The next day the sound setting are back to normal and the Dummy output setting is gone.

  • Eliah Kagan

    In a terminal, I ran gstreamer-properties, forced both input and output to ALSA Advanced Linux Sound Architecture, and rebooted. Then it worked fine!

  • Vladimir S.