printing - Install Brother MFC-5895cw Ubuntu 12.04

19
2014-04
  • semicolon

    I tried to install a MFC-5895CW Brother printer on Ubuntu 12.04, I have done this before on previous versions of Ubuntu, but it seems that it is not supported by Brother anymore for Ubuntu 12.04? You should know that this is a network printer, and I do not have a physical connection to the printer.

    Anyways, I have tried to install the drivers exactly according to the instructions on the Brother website, but these are really deprecated and do not work at all. I followed the instructions. But some files, which the instructions refer to, are missing, or other similar problems.

    I also tried to add the printer in Ubuntu, it finds the printer on the network, but is unable to find any drivers for this particular Brother printer. I hope some of you have experience with this problem or can help me in some other way, thanks!

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    printing - Brother HL-4150CDN prints text with wrong resolution on ubuntu 12.04 - Where can I fix this?
  • JB.

    I have a really nasty problem when printing with Ubuntu 12.04 x64 : Text resolution is wrong ; bitmaps and vector graphics print perfectly at 2400 or 600 dpi, but text does not. It looks ugly, resolution feels really low.

    When using Inkscape, turning texts into paths before printing solves the problem (of course, this is not an interesting workaround for everyday use).

    The printer, a Brother HL4150CDN, is used with CUPS, connected to ethernet port, and fails whatever network address (LPD or IPP) is configured in CUPS. I can print from anywhere (Firefox, Inkscape, Evince), it still fails with texts. Printer test page outputs successfully.

    The problem depends on the font used : Arial goes wrong, but Nimbus Roman feels right (some fonts are probably subtitued by the printer ?), that is probably why Courrier text whithin printer test page is correctly printed.

    I tried to reproduce this problem with previous versions of Ubuntu without success. I tried fresh installs of ubuntu 11.10 and 12.04 desktop amd64 with updates, and with the Brother driver : the problem is always there on 12.04, never on 11.10.

    The currently installed driver is the official Brother driver with PPD files, and the ia32-libs dependancy :

     hl4150cdnlpr-1.1.1-5.i386.deb
     hl4150cdncupswrapper-1.1.1-5.i386.deb
    

    Here is a scan of a really poor quality aliased text output with quality settings at 2400x600 dpi. Grid lines are spaced 0,1 in (printed from Inkscape) and i can count about 10 pixels between the lines, so the effective resolution is about 100 dpi : http://imgur.com/Y3PDd

    I captured data exchanged between computer and printer with wireshark, to compare the working version, with the buggy one. The headers are the same, but binary data are different ; screenshot using kdiff here : http://imgur.com/ilAtn

    This probably affects other printers. However, "print to pdf" and HP deskjet 920C are not affected by this.

    The questions are : How to investigate such a problem ? where can I find different settings explaining this terrible result when using Ubuntu 12.04, when comparing to 11.10 ? where to look at ? which files can I compare or edit to fix this kind of problem ?

    ps: couldn't find a launchpad bug related to this problem (will probably submit one; but I am willing to investigate this, and learn btw)


  • Related Answers
  • ewienik

    There is an example of workaround for Brother printers in https://bugs.launchpad.net/ubuntu/+source/cups/+bug/984082

  • JB.

    The workaroud provided by @ewienik points out to the right direction: the Brother PPD files are missing a required parameter (*Resolution) which bugs the pdftops component (or some other filter ?) which fallbacks to 100dpi. Here is a sample pour HL-4150CDN :

    *%==== Resolution auto Features =================================
    *OpenUI *Resolution/Quality Auto: PickOne
    *OrderDependency: 14 AnySetup *Resolution
    *DefaultResolution: 600x600
    *Resolution 600x600/Normal: " "
    *Resolution 2400x600/Fine: " "
    *CloseUI: *Resolution
    
  • beeju

    Sorry to post the comment here.The question asked 11 hours back,so an answer make your attention once more here. Did you visit this page?: https://wiki.ubuntu.com/HardwareSupportComponentsPrintersBrother