12.04 - Input device of combined audio jack not recognized anymore

24
2014-04
  • JD3

    I'm running Ubuntu 12.04 on a Lenovo T420.

    This laptop has a combined audio jack for sound in/output. Connecting my headset via a splitter adapter to the laptop results in the sound being played correctly on my headset.

    But pulseaudio does not recognize the microphone as input device anymore.

    About six months ago my workflow included using the audio jack for sound input and at that time everything worked fine. I cannot say when exactly this change happened.

    System information

    lspci -v

    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: Lenovo Device 21ce
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at f3a20000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel
    

    pactl list

    Card #0
    Name: alsa_card.pci-0000_00_1b.0
    Driver: module-alsa-card.c
    Owner Module: 4
    Properties:
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf3a20000 irq 45"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Built-in Audio"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Profiles:
        output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority. 6000)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority. 6060)
        input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority. 60)
        off: Off (sinks: 0, sources: 0, priority. 0)
    Active Profile: output:analog-stereo+input:analog-stereo
    Ports:
        analog-output: Analog Output (priority 9900)
            Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo
        analog-input: Analog Input (priority 10000)
            Part of profile(s): output:analog-stereo+input:analog-stereo, input:analog-stereo
    
  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    alsa - No audio duplex option in sound options in 12.04 on Vaio VPCS131FD
  • Jennifer Yu

    I recently did a clean install of Ubuntu 12.04 on a Sony Vaio VPCS131FD. Yet the audio duplex option is missing on my sound option and the computer no longer does jack detection. And I think the sound is a bit weaker now but I am not sure. This computer worked under 11.10.

    Alsa info

    aplay -l output:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC275 Analog [ALC275 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    

    and

    lspci | grep Audio output:

    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    

  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.