12.10 - How would I install drivers for N900 WNDA4100 wireless adapter?

23
2014-04
  • Chris-Flux

    I am currently using a N900 WNDA4100 wireless adapter, and I am unable to install the drivers for it. It is using a Ralink chipset http://www.wikidevi.com/wiki/Netgear_WNDA4100

    I found that Ralink does give support to linux http://www.ralinktech.com/en/04_support/support.php?sn=501 however, I am still rather new to Ubuntu and I was wondering if anyone could help me understand how I would install the drivers (on the Ralink website for the RT3573 USB).

  • Answers
  • Seth

    Props to Chili555 who originally gave these instructions here: http://ubuntuforums.org/archive/index.php/t-2089469.html

    Except I had to tweak them some, since the website where you get the driver has changed and the name of the folder extracted has since changed as well.

    This will let you download the driver and the usb adapter begins to work and networks appear, my problem is that now that I passed that hurdle, I've been presented with another one, mainly that I can't connect to my router even though the network appears and I have the correct WPA password. If anyone knows what to do from here I'd be stoked. Running Ubuntu 12.10 by the way.

    You will need to download RT3573 USB here: http://www.mediatek.com/_en/07_downloads/01-1_windowsDetail.php?sn=5034

    Drag and drop it to your desktop. Right-click it and select Extract Here. Now we need to modify two files.

    Navigate to os -> linux (you can also open home folder and click search and then type in the file names) and open the file config.mk with a text editor such as gedit (right-click -> open with text editor). Be certain these lines are set to =y:

    # Support Wpa_Supplicant
    # i.e. wpa_supplicant -Dralink
    HAS_WPA_SUPPLICANT=y
    
    
    # Support Native WpaSupplicant for Network Maganger
    # i.e. wpa_supplicant -Dwext
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
    

    Proofread, save and close the text editor. Now navigate to common and open rtusb_dev_id.c with a text editor. Make the change I've highlighted here:

    #endif /* RT35xx */
    #ifdef RT3573
    {USB_DEVICE(0x148F,0x3573)}, /* Ralink 3573 */
    {USB_DEVICE(0x7392,0x7733)}, /* Edimax */
    {USB_DEVICE(0x0846,0x9012)}, /* Netgear */
    {USB_DEVICE(0x0B05,0x17AD)}, /*ASUS */
    #endif /* RT3573 */
    { }/* Terminating entry */
    

    All you are doing is adding the highlighted part. All else is unchanged. Punctuation, spacing, brackets, etc. is crucial and must be exact. Proofread, save and close the text editor.

    Now we install the necessary build tools: sudo apt-get install build-essential linux-headers-generic

    Now we compile the driver:

    cd ./Desktop/20120911_RT3573_Linux_STA_v2.5.0.0_Rev1_DPO    
    sudo su
    make
    make install
    modprobe rt3573sta
    exit
    

    Your device should now be working.


  • Related Question

    installation - How do I install the driver for my Linksys AE1200 Wireless-N USB Adapter?
  • Lewis Graham

    I recently downloaded Ubuntu from the main website with the hopes of dual booting it with Windows. While the operating system works, it says that I need to install a driver for my graphics card. When I type in my password the installation fails. I figure it is because I need Internet access. I tried to install my WiFi USB adapter with the installation disc but Ubuntu doesn't seem to run the setup when I click the exe.

    What are my available solutions as I would really like to use Ubuntu from my programming and Windows for my gaming needs?

    The name as read on the box is: Linksys AE1200 Wireless- N USB Adapter

    The description reads as such:

    ID  13b1:0039 Linksys (a comma messed up format)
    ID  046d:0a0b Logitech, Inc. ClearChat Pro USB (headset)
    

  • Related Answers
  • sarnold

    It doesn't look like Cisco cares about supporting Linux on that specific device: http://homecommunity.cisco.com/t5/Wireless-Adapters/AE1200-linux-Driver/m-p/410963?comm_cc=HSus&comm_lang=en#M30247

    One user on that forum suggests the RALinkTech driver "RT3572USB" will function for your device, but suggests it will be an annoyance. I cannot confirm either statement.

    ndiswrapper (a tool that provides enough Windows APIs to let Windows drivers  run under Linux) doesn't mention your device on their supported devices list.

    In general, it is best to buy devices after  finding out their level of support. Some companies (Intel) put extra effort into making sure their hardware works under Linux (sometimes before Windows drivers are released; the members of their development teams I've talked with have been excited to support Linux). Some companies just don't care. Finding out for sure which specific devices are supported can be difficult; one simple approach is to look in /lib/modules/$(uname -r)/kernel/drivers/net/ for drivers. All the USB drivers are in the usb/ subdirectory. On my system:

    $ for f in * ; do echo -ne "$f \t" ; modinfo $f | grep ^description ; done
    asix.ko     description:    ASIX AX8817X based USB 2.0 Ethernet Devices
    catc.ko     description:    CATC EL1210A NetMate USB Ethernet driver
    cdc_eem.ko  description:    USB CDC EEM
    cdc_ether.ko    description:    USB CDC Ethernet devices
    cdc_ncm.ko  description:    USB CDC NCM host driver
    cdc-phonet.ko   description:    USB CDC Phonet host interface
    cdc_subset.ko   description:    Simple 'CDC Subset' USB networking links
    cx82310_eth.ko  description:    Conexant CX82310-based ADSL router USB ethernet driver
    dm9601.ko   description:    Davicom DM9601 USB 1.1 ethernet devices
    gl620a.ko   description:    GL620-USB-A Host-to-Host Link cables
    hso.ko  description:    USB High Speed Option driver
    int51x1.ko  description:    Intellon usb powerline adapter
    ipheth.ko   description:    Apple iPhone USB Ethernet driver
    kaweth.ko   description:    KL5USB101 USB Ethernet driver
    mcs7830.ko  description:    USB to network adapter MCS7830)
    net1080.ko  description:    NetChip 1080 based USB Host-to-Host Links
    pegasus.ko  description:    Pegasus/Pegasus II USB Ethernet driver
    plusb.ko    description:    Prolific PL-2301/2302 USB Host to Host Link Driver
    rndis_host.ko   description:    USB Host side RNDIS driver
    rtl8150.ko  description:    rtl8150 based usb-ethernet driver
    sierra_net.ko   description:    USB-to-WWAN Driver for Sierra Wireless modems
    smsc75xx.ko     description:    SMSC75XX USB 2.0 Gigabit Ethernet Devices
    smsc95xx.ko     description:    SMSC95XX USB 2.0 Ethernet Devices
    usbnet.ko   description:    USB network driver framework
    zaurus.ko   description:    Sharp Zaurus PDA, and compatible products
    

    One thing that this cannot show is the driver quality  -- which varies from driver to driver and device to device. There's nothing to be done but web searches for specific devices you're interested in and seeing if people generally have success or complaints -- knowing that most people will report complaints but not that their equipment works fine.

  • Lukashka

    I'm running Ubuntu 12.04 and after searching these forums unsuccessfully, I have installed the driver for my AE1200 and it is working correctly.

    Here is how I did it:

    First, install ndiswrapper and be sure to install ndiswrapper-common and ndiswrapper-dkms as well.

    Then, download the XP driver for the device: http://support.linksys.com/en-us/support/adapters/AE1200

    Extract the zip and cd to the folder (probably xp). If you attempt to install the driver with ndiswrapper at this point, you will receive the "couldn't find section "Linksys_AE1200.files.NTamd64"" error. To resolve this, edit the bcmwlhigh5.inf file. Find the section that looks like this:

    [Linksys_AE2500.files.NT]
    AE2500xp.sys,,,6
    

    Underneath it, add this:

    [Linksys_AE1200.files.NTamd64]
        AE1200xp64.sys,,,6
    
    [Linksys_AE2500.files.NTamd64]
        AE2500xp64.sys,,,6
    

    Save and close. Then, if you've already attempted to install the driver with ndiswrapper you'll need to remove it, run:

    sudo ndiswrapper -e bcmwlhigh5
    

    Then do the install again:

    sudo ndiswrapper -i bcmwlhigh5.inf
    

    Verify with:

    sudo ndiswrapper -l
    

    Now plug in the USB device and the blue light should come on.

    I could be wrong, but I think this means whoever wrote these .inf files forgot to include those lines, which I find funny.

    **Update for 12.10- If you install ndiswrapper-dkms it will fail and you will start getting system errors. Follow the solution here to resolve: https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/comments/3

    As a side note the source code he refers to is everything in the "driver" directory of the extracted tar.gz

    In addition, you will also want to run:

    sudo dkms remove ndiswrapper/1.57 --all
    

    and

    sudo dkms uninstall ndiswrapper/1.57
    
  • Clayton

    I just bought the Linksys AE1200 USB Wireless adapter and it works fine 19-Oct-2012.

    My lsusb results:

    Bus 001 Device 005: ID 13b1:0039 Linksys AE1200 802.11bgn Wireless Adapter [Broadcom BCM43235]

    For some reason, the Win XP driver on the installation CD would not work. None of the other broadcom chipset drivers that I attempted worked for me either.

    The solution

    So, a search of here and Ubuntuforums yielded this link: http://www.wikidevi.com/wiki/Linksys_AE1200 and provided this repaired version of the xp driver: http://wikidevi.com/files/Drivers/Broadcom/bcmwl_4323x.zip.

    1. Download the bcmwl_4323x.zip and extract (for my example to follow, my downloads directory)
    2. I opened a Terminal window:
      • cd /Downloads/bcmwl_4323x/xp/
      • :~/Downloads/bcmwl_4323x/xp$ sudo ndiswrapper -i bcmwlhigh5.inf
      • sudo modprobe ndiswrapper
    3. ndiswrapper -l yielded:

    bcmwlhigh5 : driver installed
    device (13B1:0039) present

    • Exit Terminal window, unplug LAN cable, System Restart.
    • (Optional) If the USB Wireless card does not work after reboot, you may need to add ndiswrapper to your /etc/modules so that it loads ndiswrapper at startup.
      • You should be able to test if this is needed if upon boot, the LED on your wireless card is not lit. You run in terminal sudo modprobe -r ndiswrapper | sudo modprobe ndiswrapper and then the LED turns on.
  • Nuno Machado

    Just to let the community know that Linksys AE1200 is working flawlessly as in Windows.

    But, I have to inform, that the modified XP driver, posted above on other comment, did not work on WPA2 routers, I got a workaround, and found the untouched WinXP driver, and got it up and running.

    Did it the following way:

    Downloaded XP driver UNMODIFIED from: http://drivers.softpedia.com/dyn-postdownload.php?p=159439&t=0&i=1

    Installed ndisgtk and ndiswrapper-dkms packages via terminal ==> sudo apt-get install ndisgtk && sudo apt-get install ndiswrapper-dkms

    Extracted the zipped WinXP driver downloaded from the link above.

    Opened Windows Wireless Drivers from the menu, chose the bcmwlhigh5.inf file and installed the driver.

    Rebooted just to be sure and finally got it working.

    I'm running Lubuntu at the moment, but, I assume in that in Ubuntu and also in Ubuntu derivatives, there is no need to add ndiswrapper to /etc/modules as in Lubuntu ndiswrapper is loaded by default by the kernel.

    Well hope this helps anyone, the easy and hassle-free way to set Cisco Linksys AE1200 USB wireless dongle to work, without too much terminal commands, for less experienced users!

    EDIT: If you're in a situation that you cannot by any means reboot, right after the driver install, the blue LED should be immediatelly on, and you can start using the wi-fi dongle right away.