10.04 - How do I set up an MTS MBlaze modem?

24
2014-04
  • codingfreak

    I got a new MTS MBlaze Broadband modem USB and it is not getting detected in my UBUNTU 10.04. It is getting detected as a USB but not as MODEM as result I am not able to create a MOBILE BROADBAND connection :(

    Any workarounds or tutorials available to use MTS MBlaze modem on UBUNTU 10.04 ??

    Thanks in Advance

  • Answers
  • B. Roland

    There two ways to setup MBlaze USB Modem in Ubuntu:

    1. Using driver software which included in the modem itself. (Recommended)
    2. And without any driver software.

    Using recommended driver software

    The modem itself contains the driver software for both RPM and DEB based GNULinux distros, Mac OS and Windows. From these, we Ubuntu users, have to install CrossPlatformUI-V2.1.2-SSTL-i386-ubuntu.deb package. If you are using 32 bit Ubuntu then it is not going to be a big headache. Just install it after connecting the USB Modem. But, if you have 64 bit Ubuntu then this one is not going to work as it is build for 32 bit systems only. For that we need to re-build this 32 bit only into 64 bit also driver software.

    For Non-advanced users

    If you are not familiar with executing commands in terminal or do not want to spend your valuable time, simply download the package provided below which we had re-built ourselves.

    Download CrossPlatformUI-V2.1.2-SSTL-ALL-ubuntu.deb

    And install this after connecting the modem. It will work for sure because we are using it right now.

    For Advanced users

    1. First we need to install Dpkg. Dpkg is a terminal based application that help to install, remove, unpack, build the *.deb package files.
    2. To install Dpkg, connect to Internet and execute sudo apt-get install dpkg in terminal.
    3. Extract CrossPlatformUI-V2.1.2-SSTL-i386-ubuntu.deb file.
    4. Open extracted directory->DEBIAN and open control file in a text editor.
    5. Now replace the Architecture from i386 to all.enter image description here
    6. Save the file and close it.
    7. In terminal, execute sudo dpkg -b <extracted directory name> <deb filename>
      For example, sudo dpkg -b CrossPlatformUI-V2.1.2-SSTL-i386-ubuntu CrossPlatformUI-V2.1.2-SSTL-ALL-ubuntu.deb

    You may now find a new CrossPlatformUI-V2.1.2-SSTL-All-ubuntu.deb file has built along with the extracted directory. This is the same one which we have provided above to download. Install this driver package after connecting the USB Modem.

    And remember, you can also use this package for any other Ubuntu based distros.

    Without any driver software

    MTS MBlaze USB Modem also can be used without installing driver software since latest version of Ubuntu (or any other GNULinux distro) support this modem by default. It should be at least 10.04 or greater version of Ubuntu.

    1. Connect the modem with the PC. The system will detect the device automatically.
    2. Look out for the notification saying Device recognized USB Modem, ONDA Communication S.p.A., then click on the icon of Network Connections in system tray.
    3. You will find an option New Mobile Broadband (CDMA) Connection, click on it.
    4. A new window will open to setup a mobile broadband connection. Click Forward button
    5. Select India as country, then Forward,
    6. Select MTS MBlaze from the providers’ list, Forward,
    7. And then click Apply,
    8. Now Disconnect the connection which is trying to connect automatically. Because it is not going work until we provide username and password.
    9. Open Edit Connections->Mobile Broadband (Tab)->Select MTS MBlaze Connection and click on Edit.
    10. Under Mobile Broadband, type [email protected] as username and MTS as password.
      enter image description here
    11. Check Available to all users and Connect automatically if you want.
    12. Save it and close Network Connections.
    13. Now take off the modem from the port and reconnect it.
    14. After the modem get recognised by the system, try to connect Internet.
    15. If everything goes right, you will see that your Internet connection will get connected.enter image description here

    Happy Browsing. :)

    Source: How to setup MTS MBlaze USB Modem in Ubuntu GNULinux

  • Kris Harper

    It's very easy to connect in ubuntu 11.04

    1. plug in the modem and wait for few seconds

    2. on the taskbar we have the icon for network connection

    3. just click on it and a window will popup

    4. select mobile broadband in the window

    5. your modem(mine mts mblaze) will probably be displayed

    6. select country and apply

    7. credential window will popup fill in username([email protected]),password(mts),number(#777),also check on the upper part of this window the automatic connection checkbox.

    8. save it

  • Jorge Castro

    Permanent solutions is going to be usb-modswitch if U r only using MTS or Reliance. If U go for GSM modems like Docomo, Vodafone or Airtel then U may face problem with modswitching. The U need to remove mod switch. So its going to be little tricky. I am in search for a permanent solution for both issues. Will post here if I get it resolved.

  • Mohammed Nafees

    When your modem gets detected, add a new mobile broadband connection. Username: internet@internet@mtsindia.in Password: 777 Number: #777

    I did this and it works Good Luck!

  • Geppettvs D'Constanzo

    Have you tried ejecting the modem? Do not unmount. Simply eject the USB mode which will result in the modem be recognized as a modem. Then it will be available as an internet connection in your favorite Network Manager.

    The setup then will be achieved by simply clicking on the connection and following easy setup process.

    This worked for me in the Huawei Modems listed here: How do i configure huawei usb modem

    Give ejecting a try and please inform.

    Good luck!

  • Ubuntuser

    I have got Reliance Netconnect Boradband+ working in Ubuntu 10.10. Here's the link for the tutorial. See if it helps. http://www.tuxtrix.com/2011/01/how-to-setup-reliance-netconnect-mobile.html

  • Akshay Gupta

    This solution will work for EC-156 devices (tested on MTS and Tata Photon).

    Please ensure that you have installed the following packages

    • usb-modeswitch-data
    • usb-modeswitch

    Connect the device and see whether it is detected automatically in the network manager if not do the following things. .Open the terminal .Type

    Code:

    sudo nautilus
    

    A new window will be opened for root .Go to filesystems ----/etc/usb_modeswitch.d .Create a new config file named 12d1:1505 .Cut and Paste the following

    Code:

    DefaultVendor= 0x12d1 
    DefaultProduct=0x1505 
    MessageContent="55534243123456780000000000000011062000000100000000000000000000"
    

    Save the file.

    Go to terminal.

    Go to the path by the code

    Code:

    cd /etc/usb_modeswitch.d
    

    .Type the command

    Code:

    sudo usb_modeswitch -I -W -c 12d1\:1505
    

    It may connect automatically...

    Just wait for one minute.

    The default network manager may detect your device and follow the instructions by it mark it to connect automatically in the mobile broadband edit options. If not open your network mannager go to manage connection open the mobile broadband and add a new connection if it detects installed CDMA device or Huawei EC156 follow the instruction given by the network manager mark it to connect automatically in the mobile broadband edit options

    **{

    For MBLAZE:

    username:[email protected]

    password:MTS

    }**

    Reboot your system and see it is connected automatically. If not you have to type the two codes mentioned above all the times when you connect your device. It will be very diffficult to type the codes all the time....so go for the following steps to run that commands automattically

    STEPS Script to run the modeswitch command in boot steps

    1. Open the gedit.
    2. Type the two commands which you want to run in two separate lines.
    3. save the file with the extension .sh on the disk where ever you want and make this file as executable in the properties.
    4. Then right click on the desktop.
    5. Create launcher.
    6. Set type as Run in terminal.
    7. Give your desired name.
    8. Give the path of file with the extension .sh in the command box.
    9. Hit ok.

    Open the launcher..... enter the password if required

    You can change your icon in the properties of the new launcher file

    Connect your device when ever required and click the new icon on the desktop Hit the password..... enjoy...


  • Related Question

    3G USB Modem Not Working in 12.04
  • Seyed Mohammad

    When I connect my 3G USB Modem to my laptop with 12.04, nothing shows up in Network-Manager. This modem is working in 11.10 and the modem is shown in Network-Manager but not in 12.04 !!

    Here are the outputs of lsusb and usb-devices on two machines , one with 11.10 and the other with 12.04 :

    Ubuntu-11.10 :

    $ lsusb
        Bus 002 Device 009: ID 1c9e:6061  
    
    $ usb-devices
        T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  9 Spd=12  MxCh= 0
        D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
        P:  Vendor=1c9e ProdID=6061 Rev=00.00
        S:  Manufacturer=3G USB Modem        ￴￴
        S:  SerialNumber=000000000002
        C:  #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
        I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
        I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
        I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
        I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    

    Ubuntu-12.04 :

    $ lsusb
        Bus 002 Device 003: ID 1c9e:6061 OMEGA TECHNOLOGY WL-72B 3.5G MODEM
    
    $ usb-devices
        T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
        D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
        P:  Vendor=1c9e ProdID=6061 Rev=00.00
        S:  Manufacturer=Qualcomm, Incorporated
        S:  Product=USB MMC Storage
        S:  SerialNumber=000000000002
        C:  #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
        I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
    

    As the output of the above commands show, the device is detected as a modem in 11.10 but in 12.04 it is detected as a USB storage (the device is both a 3G Modem and a SD-card USB adapter).

    Any help ?!


  • Related Answers
  • LeonardPeris

    After a lot of searching and reading in different forums I found a solution to my problem. Please note that while the other answers didn't solve my problem, they might be helpful to others facing problems with 3G USB Modems (specially the sakis-3g script).

    I found my solution in this thread, which I will detail in the following:

    When connecting my USB modem, it is detected as a USB storage. According to that thread, running sudo modprobe option could make the device be detected as a modem. If not, it is also suggested to execute the following commands:

    sudo su
    echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id
    

    where 1c9e 6061 is the device ID obtained from the lsusb command. This worked for my device and it was detected in Network-Manager. Note that you must become root using sudo su and running the command with sudo won't work.

    To automate things, the following steps are presented:

    1. sudo su
    2. nano /usr/bin/usbModemScript and put the following in the file:

         #!/bin/bash
         echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id
      

      Then save the file (Ctrl+O) and exit nano (Ctrl+X).

    3. chmod +x /usr/bin/usbModemScript

    4. nano /etc/udev/rules.d/option.rules and put the following in the file:

          ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/usr/bin/usbModemScript"
          ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/sbin/modprobe option"
      

      Then save the file (Ctrl+O) and exit nano (Ctrl+X).

    5. reboot

    NOTE : You should replace the values 1c9e and 6061 with the appropriate device ID values of your own modem.

    After reboot, your modem should be detected when connecting it to the computer. Of course, this might not be the case (as it wasn't for me)! My device wasn't detected correctly after the first time it was connected to the computer. Instead, I had to disconnect and then reconnect it, and this time it was correctly detected as a modem in the Network-Manger. Some people might also need to restart the network-manager service (as I did):

    sudo service network-manager restart
    

    ================================================================================

    Another potential solution is to use wvdial.

    1. Installation: sudo apt-get install wvdial
    2. Connect your modem to the computer.
    3. Run: sudo wvdialconf /etc/wvdial.conf. If it says 'no modem found' then you are out of luck!
    4. If the modem is found, run: sudo nano /etc/wvdial.conf and input your ISP information where needed by filling the fields you know about. Run man wvdial.conf in a separate terminal for information about the options. Once you are ready, save the file (Ctrl+O) and exit nano (Ctrl+X).
    5. Now try to connect: sudo wvdial

    For more information on wvdial, read the man page (i.e. man wvdial).

    Hope this helps :)

  • Seth

    I have Huawei E156 HSDPA (3G) USB Stick and I did the following, also it worked for my samsung 3g mobile via usb cable.

    sudo apt-get install wvdial
    

    after installing wvdial type following lines in terminal to edit wvdial.conf

    sudo gedit /etc/wvdial.conf
    

    Paste into your editor, the following lines:

    [Dialer name]
    Modem Type = Analog Modem
    Phone = *99#
    ISDN = 0
    Baud = 460800
    Username = " "
    Password = " "
    Modem = /dev/ttyUSB0
    Init1 = ATZ
    Init2 = at+cgdcont=1,"ip","your Access Point Name"
    Stupid Mode = 1
    

    Whenever you have to connect just type in your terminal

    sudo wvdial name
    

    Now you will be online with blazing speeds. I think this method is less time consuming and fast than another method.

  • Sathya

    try

    sudo modprobe usbserial vendor=0x1c9e product=0x6061
    

    And wait for some time. It always works for me

  • Wilsonzaizai

    Did you install usb-modeswitch ? Ubuntu 10.10 must have come along with it . Try to check with Synaptics whether usb-modeswitch is installed . Once installed , plug in your USB modem and wait . There will be an option at the connectivity icon where it writes create new mobile broadband . Then follow the steps from the window . Im using usb modem with Ubuntu 10.10 and it runs fine . =)

  • Open Help

    I have a huawei-ec1261 modem and I made it work following this

    http://open-help.blogspot.com/2010/10/how-to-setup-tata-photon-plus-on-ubuntu.html

    Hopes it helps u too

  • Steve

    have you tried to use usb_modeswitch:

    http://wiki.ubuntuusers.de/USB_ModeSwitch

    to change the type from USB MMC Storage to 3G USB Modem?

  • srinathhs

    Do you know what brand and model your modem is? Huawei, Option or Sony Ericsson? Some Huawei models need some tweaking. At the danish site here: http://scripts.linux.dk/joomla/index.php/mobilt-bredb%C3%A5nd/mobiltbredbans.html you can download and run a script that will make most Huawei models work. You can translate the page with google translate ;-)

  • Subv3rsion

    For this USB MODEM, try sakis-3g. You can download it: http://www.sakis3g.org/#downloading

  • BigSack

    Just, use alternative connection, full update ubuntu. Connect again using your 3g Dongel.

    And it will work fine!

  • geezanansa

    I have an idea as net setter is working in ubuntu 10.04, 11.04 etc.
    Connect & add a mob bb connection in network manager. For help with Network Manager look here