12.04 - How do I change the theme of the Arduino IDE?

23
2014-04
  • AsheeshR

    The theme.txt file is said to be somewhere in the the themes folder, which itself has to be in the Arduino folder in /lib or /usr/lib, but I cant find either of the files.

    Where are the files located ?

    Is there any other way to change the theme ?

    *theme=color-scheme

  • Answers
  • belacqua

    Try running sudo updatedb then locate arduino or locate theme.txt or a related search.

    On my system, I see theme.txt in the installation directory:

    ./arduino-1.0.3/lib/theme/theme.txt

    A related issue is discussed on this blog :

    To make Arduino use the native Swing windowing instead of forcing the GTK look and feel [...] change the following line:

    #comment out this line:
    #java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base
    
    #change it to this:
    java processing.app.Base
    

    If this is still relevant, you might be able to work with themes by changing GTK theming directly.


  • Related Question

    chmod - Changing permissions on serial port
  • Terrik

    I'm using the Arduino IDE in Ubuntu, and am having issues with the serial port. It has worked in the past, but for reasons that may be unnecesary, I felt the need to change the ownership of some of the files from root ownership to my users ownership.

    This made the IDE work correctly, but I lost the ability to use the correct serial port. In the dev folder, the port I need is listed as permission 166. Someone (who is no longer in the area to help me) swapped the permissions to 666, which made it all work gloriously.

    However, it reverted back as soon as I restarted my computer, and if I now try to use the command:

    sudo chmod 666 ttyACM0
    

    nothing happens. No error messages, but no permission change either.

    How can I change it, and how can I get it to change permanently.

    I apologize if this question is overly simplistic or unclear, I'm an ubuntu noob, and I wouldn't begrudge feedback!


  • Related Answers
  • orian

    The issue with the permissions for /dev/ttyACM0 can be permanantly solved by adding yourself to the dialout group. You will have to logout and then log back in before the group change is recognized.

    You can do this with sudo usermod -a -G dialout terrik if terrik is your username.

  • Don Kirkby

    I couldn't get Rinzwind's suggestion to work, because it complained that the user account already exists. Instead, I used this command to add an existing user (terrik) to an existing group (dialout), as described on the Ubuntu Help Wiki.

    sudo adduser terrik dialout
    

    Also useful is this command for listing your current groups, although as Rinzwind says, you have to log out and log in before the serial port starts letting you in.

    groups terrik
    
  • gbmhunter

    I couldn't get Terrik's answer working, but I could if I made this slight adjustment to the path for ttyACM0.

    sudo chmod 666 /dev/ttyACM0
    

    Would post as a comment but I don't have the privileges for that yet...