64 bit - How can I run Citrix Receiver on 13.04 x64?

24
2014-04
  • lastDINO

    I am trying to install Citrix receiver on Ringtail and I seem to be having a dependency issue. I have installed the correct architecture, but it requires a separate install of Open Motif. OpenMotif install fails: "Dependency is not satisfiable: xlibs-dev." Any ideas? Thanks in advance!

  • Answers
  • Warren Hill

    I had a similar problem after virgin install of 13.04.

    Found this article What to do after installing Ubuntu 13.04

    Inside it found these 2 things that worked for be

    sudo apt-get update && apt-get upgrade
    sudo apt-get install ia32-libs
    

    Then followed instructions on CitrixICAClientHowTo again Citrix worked, problem seemed to be nspluginviewer was still 32-bit and I had not installed the ia32-libs correctly until I did 2 things above.

  • gravity

    This walkthrough was able to get Citrix Receiver installed (and circumvent Citrix's install package errors) for me:

    http://www.guyrutenberg.com/2012/12/22/installing-citrix-receiver-on-ubuntu-64bit/

    If you still run into issues, let us know how you're trying to install the package (ie: via Software Center? dpkg? etc.). You may want to remove icaclient via apt-get first, before doing anything else. It seems Citrix's install package is rather finicky and not working in a lot of cases.


  • Related Question

    11.04 - How do I install Citrix receiver?
  • krondor

    Has anyone managed to get the Citrix receiver client working in 64-bit Natty (11.04). It seems libmotif4 won't install multi-arch (32 bit and 64 bit libraries). I also see crazy dependency errors despite the libraries being present.

    Here is what I received initially when trying to install icaclient.deb from Citrix;

    sudo dpkg -i Downloads/icaclient_11.100_i386.patched.deb 
    dpkg: error processing Downloads/icaclient_11.100_i386.patched.deb (--install):
     package architecture (i386) does not match system (amd64)
    Errors were encountered while processing:
     Downloads/icaclient_11.100_i386.patched.deb
    

    I then installed the 32 bit libraries.

    sudo apt-get install ia32-libs ia32-libs-gtk

    Then I noticed libmotif4 (a dependency of the citrix client) wasn't present so I installed the 64bit version.

    sudo apt-get install libmotif4

    I then tried to force the 32 bit version;

    sudo dpkg --force-architecture -i Downloads/libmotif4_2.3.3-5_i386.deb    
    dpkg: warning: overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package libmotif4:i386.
    dpkg: error processing Downloads/libmotif4_2.3.3-5_i386.deb (--install):
     libmotif4:i386 2.3.3-5 (Multi-Arch: no) is not co-installable with libmotif4:amd64 2.3.3-5ubuntu1 (Multi-Arch: no) which is currently installed
    

    So I uninstalled the 64 bit version and tried to install the 32 bit version. This worked, but when I attempt to install Citrix I enter dependency hell.

    sudo dpkg --force-architecture -i Downloads/icaclient_11.100_i386.patched.deb 
    dpkg: warning: overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package icaclient:i386.
    (Reading database ... 183036 files and directories currently installed.)
    Unpacking icaclient:i386 (from .../icaclient_11.100_i386.patched.deb) ...
    dpkg: dependency problems prevent configuration of icaclient:i386:
     icaclient:i386 depends on libc6 (>= 2.3).
     icaclient:i386 depends on libice6 (>= 1:1.0.0).
     icaclient:i386 depends on libsm6.
     icaclient:i386 depends on libx11-6.
     icaclient:i386 depends on libxaw7.
     icaclient:i386 depends on libxext6.
     icaclient:i386 depends on libxmu6.
     icaclient:i386 depends on libxp6.
     icaclient:i386 depends on libxpm4.
     icaclient:i386 depends on libxt6.
    dpkg: error processing icaclient:i386 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
    icaclient:i386
    

    So the state it's in, there's no icaclient binaries installed only the docs. It is complaining about libraries that are indeed present (libc6 64 bit and 32 bit). libmotif4 is only 32 bit installed and won't install alongside libmotif4 64 bit.

    libmotif4 error when you try to install it alongside the 32bit instance;

     libmotif4:amd64 2.3.3-5 (Multi-Arch: no) is not co-installable with libmotif4:i386 2.3.3-5ubuntu1 (Multi-Arch: no) which is currently installed
    

    Any tips?


  • Related Answers
  • Ryan Fisher

    Already documented here, on the Ubuntu Community Documentation site.

    The HOWTO explains how to install the 32-bit Citrix ICA client on either a 32-bit or 64-bit Ubuntu host. The process definitely looks compatible with other distros as well, since it:

    1. Avoids using the Apt packaging system, opting to install the ICA Client from a tarball.
    2. Describes how to identify the 32-bit libraries you may need using native tools like ldd.
    3. Explains how to resolve the 32-bit library issue by extracting only the required libraries from a .deb package and manually copying and linking them, which is easily translated to other distro package management schemes.
  • Eliah Kagan

    They now provide a 64-bit version of the .deb package. Unfortunately, the 64-bit package checks if the system is a 32-bit system. Obviously, the check fails.

    I've modified the package to properly check for 64-bit system (and 32-bit actually for no reason really).

    You can find my modified package here.

    It was literally a one character change to postinst. Hope this helps somebody.

    Oh, please note that you will still need to copy or link to your certs directory.

  • Tom

    I made sure that I uninstalled the 64 bit package, and dpkg --force-architecture -i libmotif4*i386.deb so that I installed the 32 bit package,http://ftp.au.debian.org/debian/pool/non-free/o/openmotif/libmotif4_2.3.3-5_i386.deb, you can only have one or the other installed, not both at the same time as far as I know.

    My Citrix receiver now functions. Regards,Tom.

  • uzhoasit

    Use Getlibs

    (You will find getlibs in ppa:jcollins/jaminppa)

    getlibs -w  getlibs -w http://launchpadlibrarian.net/62541723/libmotif4_2.3.3-5ubuntu1_i386.deb/libmotif4_2.3.3-5_i386.deb
    
    sudo ln -s /usr/lib/libXm.so.4 /usr/lib32/libXm.so.4
    

    The ICA client should now start normally:

    # /usr/lib/ICAClient/wfcmgr -icaroot /usr/lib/ICAClient