compiz - Failed to load session "ubuntu"

23
2014-04
  • harsh

    I installed CCSM to enable window previews in Unity. But when I went into extras, there was no 'window preview' option.

    So I tried experimenting with other options in Compiz and now there are no borders in the dialogue boxes (close, minimize, restore buttons are not there, I had enabled some 'flat....' option in Compiz.

    Later, I uninstalled Compiz and then reinstalled it. Now it says

    "Failed to load session Ubuntu"

    I can't even access through the guest account, I am new to Ubuntu.(please explain in detail).

    All I have access to is the login screen (it still shows my custom wallpaper). Please help, I don't want to lose my stuff.

  • Answers
  • s.m

    Open virtual console : Ctrl+Alt+F1

    sudo apt-get update

    sudo apt-get install ubuntu-desktop

    sudo apt-get install -f install

    sudo dpkg-reconfigure ubuntu-desktop

    sudo reboot

    Then try to login, This will bring back your desktop

  • Linh Lino

    I got the same problem ""Failed to load session Ubuntu"" when I was trying to login afer uninstall Compiz.

    I tried to boot from USB with Live Ubuntu inside and others ways but it doensnt work.

    At the end, it comes up with a simple solution.

    1. Boot your Ubuntu as normal
    2. When you see the log-in screen, try to Ctrl - Alt - F1
    3. In my case (ubuntu 12.10), a blank screen appears. dont be panic, try Ctrl - Alt - F2
    4. A login console shows up and ask you to login using your id and password.
    5. After login. Run these commands. (tested)

    sudo apt-get update
    sudo apt-get install unity-2d
    sudo apt-get install ubuntu-desktop
    sudo apt-get install compizconfig-settings-manager
    sudo apt-get install compiz-plugins-extra
    sudo apt-get update

    I got this above list of commands from How can I remove and re-install Unity? but some doesnt work so I mentioned only good-running command in my case. I highly recommend to restart your system before try to login again.

    sudo shutdown -r now

    Hope it helps you to solve your problem.

    Linh

  • TomKat

    Try booting into the LiveDVD and install Compiz. It's possible that you disable Unity. Update Unity.

    Add the following PPA to your Software Sources per these instructions: ppa:unity-team/staging sudo add-apt-repository ppa:unity-team/staging

    After adding, open the 'Software Updater', click ‘Check for Updates’, and proceed to install those you’re prompted to do.

    This can also be achieved via the Terminal by running:

    sudo apt-get update && sudo apt-get dist-upgrade

    Restart your computer.

  • Dennis

    For me it seems to have been related to having a Cinnamon desktop installed that I was playing around with. Once I removed it using Failed to load session "ubuntu" - Ubuntu 13.10 on MacBook Pro everything was fine. ( I don't have a macbook pro, it was the same on my Dell desktop).


  • Related Question

    notification - "Failed to load session "ubuntu"" problem
  • Manuel Neuer

    I run Ubuntu 12.04. After installation I have disabled guest account, removed error notification, gave myself super user rights. I made some applications in /usr/applications useable only for me, created standard user account.

    Then I pressed restart in shut down menu, but system just logged off. After rebooting by Terminal there was "Failed to load "ubuntu"" notification.

    I don't know if it was my fault, but really have to fix that problem. By the way, I have no internet access for that PC. Hope you will help me!


  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.