chromium - Youtube says "This video is currently unavailable"

24
2014-04
  • guissmo

    Chromium on Ubuntu 12.04. Youtube says:

    This video is currently unavailable

    I don't know why but this is the case for some videos, but not all. Well, most videos. And I don't know what's wrong.

    Anyone help?

  • Answers
  • stevenmirabito

    You can test to see if it's a problem with Chromium's built-in Flash player by joining YouTube's HTML5 trial, which will switch you over to YouTube's new HTML5 video player. If the videos work then, something is messed up with your installation of Chromium/Flash player. Try reinstalling it. If they still don't work, it may be a problem on YouTube's end or your ISP's end or somewhere in between. Could you comment with an example of a video that's giving you this error?

    Also, does this appear to be a YouTube error, or an error that you're receiving from Flash/Chromium?

  • Alexander Borodulya

    I'm using Chromium Version 28.0.1500.52 Ubuntu 12.10 (28.0.1500.52-0ubuntu1.12.10.3) and faced with same issue. To solve issue you need to remove current set of chromium codecs:

    sudo apt-get remove chromium-codecs-ffmpeg
    

    And them install similar, but extra package:

    sudo apt-get install chromium-codecs-ffmpeg-extra
    

    YouTube trouble will be removed and video will be played.

    So, common solution leads to update chrome/chromium codecs.

    You can also be faced with proposition to install chromium-codecs-ffmpeg-extra while removing chromium-codecs-ffmpeg. Just apply suggestion to install package with extra version.

    Additionally, will be useful to update current version of chromium browser to take newest version:

    sudo apt-get install chromium-browser
    

    Thanks

  • zrajm

    Fix this problem by replacing the default, limited set of patent-free codecs, with the package containing all codecs. Run:

    sudo apt-get install chromium-codecs-ffmpeg-extra
    

    (Answer yes when asked if you want to remove chromium-codecs-ffmpeg and have chromium-codecs-ffmpeg-extra installed instead.)

    After the install, you'll need to restart Chromium.

    Why this happens

    Chromium is (for political/ideological reasons) by default only installed with patent-free codecs (Ogg, Vorbis and Theora), which means that much video and audio content on the web will be in formats that Chromium does not understand.

    The chromium-codecs-ffmpeg-extra package contains both the patent-free, and a bunch of (widely used) patented codecs.

    Description of the chromium-codecs-ffmpeg-extra package:

    This package contains the multi-threaded ffmpeg codecs needed for the HTML5 <audio> and <video> tags. In addition to the patent-free ogg, vorbis and theora codecs, aac / ac3 / mpeg4audio / h264 / mov / mp3 are also included. See chromium-codecs-ffmpeg if you prefer only the patent-free codecs

  • Mantas Vaitkūnas

    Same issue. In http://www.youtube.com/html5 player was set as flash. Problem was with cookies i deleted all browser cookies, than went to http://www.youtube.com/html5 enabled and disabled html5, than in new tab video started to work.

  • Ben Zyl

    But switching to viewing through a proxy server usually fixes the problem, it seems to be something to do with the region definition for the browser as Firefox seems to work unaided.


  • Related Question

    chromium - YouTube shows "Missing Plug-in" in window after installing Flash
  • gilloz

    After installing Ubuntu 12.04 LTS 32-bit, I have installed Ubuntu Restricted Extras, configured Medibuntu, and installed Synaptic Package Manager. I tried to install Adobe Flash Player by installing Chromium. I also files to play encrypted DVDs. I haven't been able to locate the flashplayer file in the /usr/lib folders, which I assume should be there. I don't know if this is why I can't see videos at YouTube. Not sure where else to look.


  • Related Answers
  • WarriorIng64

    The file should be located in /usr/lib/flashplugin-installer/. For my Flash problem, the only solution that worked was downgrading. I wrote a script as I became tired of downgrading. Here is the code below:

    wget http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.63_archive.zip
    unzip fp_11.1.102.63_archive.zip tar -xzvf
    fp_11.1.102.63_archive/11_1r102_63_32bit/flashplayer11_1r102_63_linux.i386.tar.gz
    -C fp_11.1.102.63_archive/ sudo cp -f fp_11.1.102.63_archive/libflashplayer.so
    /usr/lib/flashplugin-installer
    
  • WarriorIng64

    Install the flashplugin-installer package to install Flash.

    To play encrypted DVDs you need libdvdcss2 from the Medibuntu repository; note that this is illegal in some countries.

    To install both from the terminal (after adding Medibuntu):

    sudo apt-get install flashplugin-installer libdvdcss2
    
  • Allan

    Install Flash

    As I explained in my comment Google chrome is the only browser with flash pre-installed for everything else there is the adobe flash plug-in just search for it in the software centre

    Hope this helps

  • WarriorIng64

    Just as a check, have you tried restarting your browser after installing Flash? Sometimes Flash won't start working until you do so. You could try restarting Ubuntu as well and see if that has any effect.