12.04 - Cant install Windows programs with Wine

19
2014-04
  • LinuxPCplus

    I am trying to install a couple Windows programs. I have tried Wine itself, PlayOnLinux & Crossover. No matter which one I try, I get the same error message: "access denied" I tried logging in as root, thinking this would work, but still got the same results. I am running Ubuntu 12.04, 32 bit. ADDITIONAL DETAILS AS REQUESTED: I am using installation CD's. I have been able to install Windows programs before, so this is a new problem that occurred after updating my system. All was fine before that. The install files are on the CD's. Permissions? I assume so since as I said, I had installed other Windows software without issue BEFORE the upgrade. And yes, I have checked compatibility & all 3 programs are said to work well in Wine/Crossover.

    The prgrams I am trying to install are: 1. Age Of Empires III(Crossover rank: Gold) 2. Quicken 2011 (Crossover rank: Silver) 3. Steam (Crossover rank: Silver)

    UPDATE: Iright click on the .exe file & allow executing as program is not selected. Also, it wont let me change them, says permissions could not be changed.

  • Answers
  • JohnColtraine

    Well, obviously the windows installer needs permissions! I had the same problem! I did the following:

    • I burned the CD into an ISO imagefile
    • Then i mounted the ISO file with the FuriusIso Mount
    • After that, i opened a terminal and typed: gksudo nautilus (it will open a file browser with root access!)
    • Now find the mounted ISO path and edit the installer file's properties
    • Done!

    Good Luck!

  • jemadux

    wine is just an emulator so the windows programm emutlator so sometimes wine can not run windows programms ...

    go Wime HQ site and look if your programm supported ...


  • Related Question

    12.04 - PlayonLinux install menu is empty
  • Karthik

    I am using Ubuntu 12.04.

    I installed PlayOnLinux by adding their repository to Software Sources. My PlayOnLinux version is 4.1.2

    When I try to install a program the install menu is totally empty.enter image description here

    So, I tried running PlayonLinux from terminal and this the output I got.

    Traceback (most recent call last):
    File "/usr/share/playonlinux/python/install.py", line 315, in search
    self.apps = codecs.open(Variables.playonlinux_rep+"/configurations/listes /search",'r',"utf-8")
    File "/usr/lib/python2.7/codecs.py", line 881, in open
    file = builtin.open(filename, mode, buffering)
    IOError: [Errno 2] No such file or directory: '/home/karthik/.PlayOnLinux//configurations/listes/search'
    Traceback (most recent call last):
    File "/usr/share/playonlinux/python/install.py", line 434, in AddApps
    self.apps = codecs.open(Variables.playonlinux_rep+"/configurations/listes/4",'r',"utf-8")
    File "/usr/lib/python2.7/codecs.py", line 881, in open
    file = builtin.open(filename, mode, buffering)
    IOError: [Errno 2] No such file or directory: '/home/karthik/.PlayOnLinux//configurations/listes/4'

    I searched the playonlinux forums and found a discussion which matched the problem. Eventhough, I followed the instructions there, the problem did not get solved.

    Also, I am behind an authenticated proxy server. I filled the proxy server details in the PlayonLinux preferences.

    I would really like get PlayonLinux working. Thanks in advance.


  • Related Answers
  • Karthik

    I uninstalled the program from PlayOnLinux repo and installed the program from the official repo. The program in the official repo seems to be working properly.