video - Can't generate thumbnails in Nautilus

16
2014-04
  • Paul Dirac

    Before I upgraded to Ubuntu 12.04, thumbnails on video files worked nicely, after the upgrade, thumbnails aren't generating on video files and only on video files, most of them are .mkv files. I have some .pdf files and they all have thumbnails. I have tried to clear the thumb cache, but no luck.

  • Answers
  • isaaclw

    Please ensure that the necessary packages are installed by running the following command in the terminal:

    sudo apt-get install gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly totem libxine1-ffmpeg
    

    Also, please delete the thumbnails that failed to load by running the following command:

    rm ~/.thumbnails/fail/gnome-thumbnail-factory/*
    

    In Ubuntu 13.10, the folder changes to: .cache/thumbnails, so you should delete those failed files instead:

    rm ~/.cache/thumbnails/fail/gnome-thumbnail-factory/*
    
  • Karthik

    I followed the instructions in this forum and it worked perfectly.

    Install libxine1-ffmpeg.
    sudo apt-get install libxine1-ffmpeg

    Then to force nautilus to generate new thumbnails execute
    rm -r ~/.thumbnails/fail
    rm -r ~/.thumbnails/normal
    killall -9 nautilus

    These commands will remove (delete) thumbnails from these folders.

    Open nautilus again and you should be able to see thumbnails for all your videos.

  • Paul Dirac

    I had to re install my ubuntu to get the video thumbnails working again, it was annoying. I couldn't fin any other way.

  • OrangeTux

    I installed ffmpegthumbnailer:

    sudo apt-get install gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly totem libxine1-ffmpeg
    

    It works in 13.10


  • Related Question

    10.10 - Missing Thumbnails for .swf files in Nautilus?
  • Questioner

    Before I upgraded to Maverick, .swf files used to have a thumbnail in Nautilus. However, Nautilus doesn't generate thumbnails for them anymore, even after removing ~/.thumbnails/, which most likely indicates that a package is missing.

    How do I get Nautilus to generate thumbnails for .swf files?

    EDIT: I've added a bounty, as I believe this question might still be answered...


  • Related Answers
  • Alvin Row

    There is a way of getting this done explained in the Floorplanner Tech Blog. To compile dump-gnash on a fresh Maverick you'll need

    sudo apt-get install gcc libboost-dev libboost-thread-dev libagg-dev libsdl1.2-dev libcairo-dev libgstreamer0.10-dev libatk1.0-dev libglib2.0-dev libpango1.0-dev libgtk2.0-dev libgtkglext1-dev libgl1-mesa-dev libgif-dev libjpeg-dev libgstreamer-plugins-base0.10-dev libspeex-dev libcurl-dev
    

    And then you just follow the steps. This will take a long time.
    NOTE: For Step 7 use the following script instead:

    if [[ $3 ]]; then
        raw="$(mktemp)"
        dump-gnash $2 -P "FlashVars=url=file://$1" -D "$raw" --max-advances 1 -j 500 -k 500
        tail -c 1MB "$raw" | convert -size 500x500 -depth 8 rgba:- -separate -swap 0,2 -combine -trim png:"$3"
        trap "rm $raw" EXIT
    else
        echo "Insufficient arguments (expected 3 arguments)"
        exit 1
    fi
    

    Once you have the final script running you just hook it into gconf-editor

    gconftool-2 -s "/desktop/gnome/thumbnailers/application@swf" -t string "/usr/bin/swfthumbnailer.sh %s %i %o"
    gconftool-2 -s "/desktop/gnome/thumbnailers/application@swf/enable" -t boolean 'true'
    gconftool-2 -s "/desktop/gnome/thumbnailers/application@x-swf" -t string "/usr/bin/swfthumbnailer.sh %s %i %o"
    gconftool-2 -s "/desktop/gnome/thumbnailers/application@x-swf/enable" -t boolean 'true'
    gconftool-2 -s "/desktop/gnome/thumbnailers/application@x-shockwave-flash/command" -t string "/usr/bin/swfthumbnailer.sh %s %i %o"
    gconftool-2 -s "/desktop/gnome/thumbnailers/application@x-shockwave-flash/enable" -t boolean 'true'
    

    Then restart (or restart gnome-settings-daemon), and you've got swf thumbs!

    P.S.: This is a huge hack. A better way to do this would be vastly appreciated.

  • JanC

    The thumbnails were made with libswfdec (i.e. /usr/bin/swfdec-thumbnailer from the package swfdec-gnome), which was removed in Ubuntu 10.10 ("maverick"). The libswfdec author stopped development because there are already 2 other open source projects working on implementing an SWF player: gnash (which is included in Ubuntu) & lightspark (which is new and not included yet). I am not sure if there exists a thumbnailer that uses gnash...

  • Jorge Castro

    The closest thing I've been able to find is perhaps using ffmmpegthumbnailer Install ffmmpegthumbnailer to create thumbnails for you and that should handle the .swf files.

    This blog post has the instructions.

  • Area 51

    Simplest answer should simply be to install swfdec-gnome, but the Lucid version. Not hard to do, just go to http://packages.ubuntu.com/da/lucid/swfdec-gnome and select your architecture. Then just do what you did previously to make it work; it seems to just randomly kick in for me, as I recall. Maybe after a log out/restart. Good luck to you.