internet - Can't connect to wifi when there's a password, realtek 8723, 13.04

20
2014-04
  • user167548

    I have seen Cant connect to wifi on 13.04 but the answer did not help and I have a realtek 8723 not 8188. I connect just fine when there is no password.thanks very much.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    11.10 - RealTek RTL8188CE WiFi adapter doesn't connect reliably
  • ken.ganong

    Possible Duplicate:
    12.10 x64 - RTL8188CE - Intermittent/Slow Internet Connection

    I recently bought a new system76 laptop which came pre-installed with Ubuntu 11.10. I've been having trouble with my wireless connectivity. It seems that my connection with my wireless network keeps going in and out. It is not my network--I have seen the same problem on multiple WiFi networks and at different distances and reported link qualities.

    OS version: Ubuntu 11.10 oneiric
    kernel version: 3.0.0-14-generic

    lspci:

    lspci -nnk | grep -iA2 net
    
    04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:9196]
    Kernel driver in use: rtl8192ce
    --
    05:00.0 Ethernet controller [0200]: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller [197b:0250] (rev 05)
    Subsystem: CLEVO/KAPOK Computer Device [1558:2500]
    Kernel driver in use: jme
    

    iwconfig:

    iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"peppermintpatty"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 98:FC:11:6C:E0:22   
              Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off
          Link Quality=49/70  Signal level=-61 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1103   Missed beacon:0
    

    lshw:

    sudo lshw -class network
      *-network               
           description: Wireless interface
           product: RTL8188CE 802.11b/g/n WiFi Adapter
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:04:00.0
           logical name: wlan0
           version: 01
           serial: 00:1c:7b:a1:95:04
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=rtl8192ce driverversion=3.0.0-14-generic firmware=N/A ip=192.168.1.106 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
           resources: irq:18 ioport:e000(size=256) memory:f7d00000-f7d03fff
      *-network
           description: Ethernet interface
           product: JMC250 PCI Express Gigabit Ethernet Controller
           vendor: JMicron Technology Corp.
           physical id: 0
           bus info: pci@0000:05:00.0
           logical name: eth0
           version: 05
           serial: 00:90:f5:c0:42:b3
           size: 10Mbit/s
           capacity: 1Gbit/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm pciexpress msix msi bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
           resources: irq:56 memory:f7c20000-f7c23fff ioport:d100(size=128) ioport:d000(size=256) memory:f7c10000-f7c1ffff memory:f7c00000-f7c0ffff
    

    Any help would be appreciated. The last time I've dealt with wireless issues, the most given solution was NDIS wrapper and I seem sorely out-of-date.


  • Related Answers
  • Bruno Pereira

    Looks very much like this bug, flaky on Oneiric and almost never working on Precise.

  • Vocal Fry

    I have been having similar issues lately with a toshiba c655d-s5300. I reverted to an older kernel at the grub menu, and now it is working. Here's what IS working:

       description: Wireless interface
       product: RTL8188CE 802.11b/g/n WiFi Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: e0:ca:94:5c:21:7a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.0.0-13-generic firmware=N/A ip=192.168.1.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11b
    

    It WAS NOT working on the 3.0.0.14-generic kernel.