broadband - Use a newer ZTE modem with usb-modeswitch

19
2014-04
  • Eshwar

    Recently, I bought a 3G HSDPA modem from Cell C (South Africa). it is a ZTE MF190 capable of 7.2Mbps up and 5.76Mbps down.

    So anyway i noticed usb_modeswitch does not support it. The details are as follows:

    before switching: 19d2:1224 after switching: 19d2:0082

    So the question is how to switch this modem? which I will provide as an answer.

  • Answers
  • Eshwar

    So how to switch the modem,

    For this model, you can just eject the fake cdrom drive and the modem switches by itself.

    For a terminal/script use:

    if you can find another configuration file that is similar to this modem, copy that to somewhere convenient, and then edit so that it reflects the device and vendor ids for this modem. then try switching using

    usb_modeswitch -c "path to config file"

    With this model, the settings for the vodafone K380* modems works. The settings are in the files 19d2:1013 or 19d2:0013 in the /etc/usb_modeswitch.d/ folder for ubuntu lucid. So just get those files, update with the details you find from lsusb for this modem and then you should be ok!


  • Related Question

    10.04 - How do I get a 3G USB modem to work?
  • Questioner

    Since at least Jaunty, I've tried to get my wife's 3G USB modem to work on Ubuntu, always with the same result - instant, complete system freeze.

    I've tried installing`wvdial and usb-modeswitch, I've read tons of documentation but it gets quite disjointed from one release to the next, nothing works. I can't run lsusb because the system hangs immediately.

    I'm using Lucid and it's a Rogers "Rocket Stick" (in Canada)


  • Related Answers
  • ΤΖΩΤΖΙΟΥ

    Try this “automagic” script: sakis3g. No need to install anything, just run the script; it will guide you through menus.

    After you make it work, you can create a small script calling the sakis3g-script having set up some environment variables for your convenience. Here follows mine:

    export BAUD=MAX MODEM=1bbb:0000 APN=3g-internet SIM_PIN=1234
    (sakis3g-script helper&)&
    

    The $MODEM is the vendor-id:product-id code so I don't have to select it everytime I start the sakis3g-script; $APN is your provider's suggested login name; the SIM_PIN is rather obvious.

    See also that question in SuperUser.

  • mniess

    The first stop should be, to figure out which chipset the stick is using and which driver is loaded (that causes the freeze). You could try running "sudo dmesg | tail -f" in a terminal while plugging in the stick. That might also help identifying the problem.

  • Stuart

    The real answer is to start with a supported device. See http://en.wikipedia.org/wiki/NetworkManager for a list of working devices.