10.10 - Can't adjust brightness on my laptop

23
2014-04
  • Wilsonzaizai

    I'm having difficulty in adjusting brightness on my Acer Aspire 4740:

    • Screen 14.1-inch glossy LED-backlit, 1366x768 res
    • CPU Intel Core i5-430M 2.26-GHz
    • RAM 1GB DDR3
    • HDD 320GB
    • Graphics Intel GMA HD

    Im using Ubuntu 10.10 . I do not have this problem in Ubuntu 10.04 , but this problem occur in Ubuntu 10.10 . I can't decrease or increase my brightness even in Compiz.

  • Answers
  • Lucas Pottersky

    I also have an ACER, but ASPIRE 4736Z. Same problem.

    xbacklight, xgamma doesn't work.

    Something that did work for me is redshift utility: http://askubuntu.com/questions/9248/is-there-a-software-utility-to-adjust-screen-gamma-brightness-contrast

  • Eliah Kagan

    Try this.

    1. Open the Terminal (Ctrl+Alt+T) and type:

      gksu gedit /etc/default/grub
      
    2. Change the line:

      GRUB_CMDLINE_LINUX=""
      

      To:

      GRUB_CMDLINE_LINUX="acpi_osi=Linux"
      
    3. Save the file and quit the text editor.

    4. Now in the terminal run:

      sudo update-grub
      
    5. Restart Ubuntu.

    Based very closely on this article: living in java

  • Eliah Kagan

    https://bugs.launchpad.net/emgd/+bug/711172

    Add to kernel command line:

    acpi_backlight=vendor
    

    And you are done!

  • Shungun

    Have you tried using Xbacklight? http://linux.die.net/man/1/xbacklight


  • Related Question

    10.10 - Multitouch on Acer Aspire 4740
  • Wilsonzaizai

    How can I enable multi touch in Ubuntu 10.10 for my Acer Aspire 4740 notebook ?

    Screen 14.1-inch glossy LED-backlit
    1366x768 res 
    CPU Intel Core i5-430m 2.26GHz 
    RAM 1GB DDR3 
    HDD 320GB 
    Graphics Onboard Intel GMA HD 
    USB Ports 3 
    DVD Writer Yes 
    Gigabit Ethernet Yes 
    Wi-Fi 802.11 b/g/n 
    HDMI/eSATA/FireWire Yes/No/No 
    Multicard Reader Yes 
    ExpressCard Slot No
    

  • Related Answers
  • Bruno Pereira

    This page describes the necessary steps to enable multi-touch.

    I used it as guide and was able to activate multi-touch on my system.

  • AndyB

    If your laptop built with Synaptics touchpad you need to install the synaptics drivers for your environment. To configure, you need gsynaptics configuration tool as well. With tose you can enjoy moultitouch features.

  • Fraekkert

    Multitouch and the synaptics driver are installed and ready for use. Have you checked the touchpad settings under System > Preferences > Mouse and the Touchpad tab?

    If you are not able to activate multitouch like me:

    alt text

    you can force the setting by

    gconftool-2 --set --type=int /desktop/gnome/peripherals/touchpad/scroll_method 2
    

    If multitouch is not working after this, try a reboot. If it is still not working, try the following script:

    #!/bin/bash
    # list of synaptics device properties http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html#sect4
    # list  current synaptics device properties: xinput list-props "SynPS/2 Synaptics TouchPad"
    #
    
    sleep 2
    
    xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 10
    
    #   Below width 1 finger touch, above width simulate 2 finger touch. - value=pad-pixels
    xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 7        
    
    #   vertical scrolling, horizontal scrolling - values: 0=disable 1=enable
    xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 1   
    
    #   vertical, horizontal, corner - values: 0=disable  1=enable
    xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Edge Scrolling" 0 0 0       
    
    #   stabilize 2 finger actions - value=pad-pixels
    xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Jumpy Cursor Threshold" 120 
    
    #xinput --set-prop --type=int --format=8 "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 0 0 0 0 1 2 0
    

    If this makes it work, put it in a file, make it executable and add it to your Startup Applications.

  • Marco Ceppi

    Create the following file with this command

    sudo gedit /etc/hal/fdi/policy/99-x11-synaptics.fdi
    

    And paste this into it.


    <?xml version="1.0" encoding="ISO-8859-1"?>
       <deviceinfo version="0.2">
       <device>
          <match key="input.x11_driver" string="synaptics">
             <merge key="input.x11_options.SHMConfig" type="string">on</merge>
             <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
             <merge key="input.x11_options.VertTwoFingerScroll" type="string">true</merge>
             <merge key="input.x11_options.HorizTwoFingerScroll" type="string">true</merge>
             <merge key="input.x11_options.EmulateTwoFingerMinZ" type="string">35</merge>
             <merge key="input.x11_options.EmulateTwoFingerMinW" type="string">8</merge>
             <merge key="input.x11_options.VertEdgeScroll" type="string">false</merge>
             <merge key="input.x11_options.HorizEdgeScroll" type="string">false</merge>
             <merge key="input.x11_options.JumpyCursorThreshold" type="string">245</merge>
             <merge key="input.x11_options.RBCornerButton" type="string">0</merge>
             <merge key="input.x11_options.TapButton2" type="string">3</merge> <!-- right button -->
             <merge key="input.x11_options.TapButton3" type="string">2</merge> <!-- not functional -->
             <merge key="input.x11_options.FingerHigh" type="string">41</merge>
          </match>
       </device>
    </deviceinfo>