12.04 LTS won't boot after nvidia driver upgrade

25
2014-04
  • V1GG3N

    This question already has an answer here:

  • Answers
  • Joren

    Reinstalling your drivers to the current version will solve this:

    You will have to boot normally, and when the black screen appears, press ctrl+alt+F1. Login, then use the following commands.

    First remove all the old drivers:

    sudo apt-get purge nvidia*
    

    Then reinstall the current drivers:

    sudo apt-get install nvidia-current
    

    Reboot, and your're good to go!

    sudo reboot
    
  • Dave Stroud

    When I was using 12.04 with nvidia and had a problem I would edit grub and add nomodeset and boot into vessa and then reinstall nvidia drivers. Usualy worked for me.I had to use nomodeset to run cd also .


  • Related Question

    boot - After Nvidia driver install, LightDM won't start automatically
  • BlueS

    I did a clean install and after installing updates and drivers (Nvidia VGA) for a 460GTX, I'm shown a black screen with various Stopping/Starting messages. The last of these messages is different (this time it's "Stopping save kernel messages") every time I try and boot up the system. Logging into tty1 and doing sudo startx or start lightdm works. Nvidia drivers seem to be working.

    Some things I've tried or noticed.

    • Problem seems to start after installing Nvidia drivers.
    • cat /etc/X11/default-display-manager spits out /usr/sbin/lightdm.
    • sudo dpkg-reconfigure lightdm gives me DPKG_MAINTSCRIPT_NAME and PACKAGE missing.
    • Also restored lightdm settings and reinstalled it.

  • Related Answers
  • Falk0n

    I had a very similiar problem just a few minutes ago: I downloaded the current driver from nvidia support site. Installation script run without problems. However, the boot process stopped shortly after the message for starting lightdm.

    The machine was completely unresponsive, only frozen black screen with the [Starting] messages. Fortunately the network was working and I could log in remotely with ssh.

    /var/log/lightdm/lightdm.log revealed that the X server exited with an error. /var/log/lightdm/x-0.org complained about different versions of the nvidia driver and the nvidia kernel module.

    I reinstalled the nvidia driver from ubuntu:

    sudo apt-get install nvidia-current
    sudo reboot
    

    Everything works fine again, but of course it's still the old driver.

  • Sneetsher

    I was also getting strange messages after a removing nVidia settings using:

    sudo apt-get remove --purge nvidia-*
    

    Then installing nvidia-current:

    sudo apt-get install nvdia-current
    

    Ubuntu got stuck at giving messages ieee80211:phy ...

    This thread helped me Failed to Start the X server.

    In summary:

    1. Login to any tty as root Ctrl+Alt+F1~F6
    2. Save a backup of your current xorg.conf file as:

      cp /etc/X11/xorg.conf /etc/X11/xorg_backup.conf
      
    3. Run command

      sudo Xorg -configure
      
    4. Copy new configuration file e.g /root/xorg.conf.new to /etc/X11/xorg.conf:

      cp /root/xorg.conf.new /etc/X11/xorg.conf
      
    5. Enter command startx

    After reboot, if every thing works fine, remove the backup file xorg_backup.conf of step (2).